aboutsummaryrefslogtreecommitdiff
path: root/databases/linux-oracle-instantclient-sdk
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2005-05-06 15:11:44 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2005-05-06 15:11:44 +0000
commitdd2a1720617e5011fc08f511f13a21398c3bfc44 (patch)
tree21e29cd015f715c60be18a358cda8a6bb350c021 /databases/linux-oracle-instantclient-sdk
parent21ab0028051261a4a37201586fcb884c7ebdd464 (diff)
downloadports-dd2a1720617e5011fc08f511f13a21398c3bfc44.tar.gz
ports-dd2a1720617e5011fc08f511f13a21398c3bfc44.zip
Add linux-oracle-instantclient-sdk 10.1.0.3, oracle 10
InstantClient SDK. Works with Oracle RDBMS 8.1.2+. PR: ports/76166 Inspired by: Alexander Novitsky <alecn2002@yandex.ru> Oked by: thierry:-)
Notes
Notes: svn path=/head/; revision=134702
Diffstat (limited to 'databases/linux-oracle-instantclient-sdk')
-rw-r--r--databases/linux-oracle-instantclient-sdk/Makefile106
-rw-r--r--databases/linux-oracle-instantclient-sdk/distinfo2
-rw-r--r--databases/linux-oracle-instantclient-sdk/pkg-descr9
-rw-r--r--databases/linux-oracle-instantclient-sdk/pkg-plist42
4 files changed, 159 insertions, 0 deletions
diff --git a/databases/linux-oracle-instantclient-sdk/Makefile b/databases/linux-oracle-instantclient-sdk/Makefile
new file mode 100644
index 000000000000..2c9c64123dde
--- /dev/null
+++ b/databases/linux-oracle-instantclient-sdk/Makefile
@@ -0,0 +1,106 @@
+# New ports collection makefile for: linux-oracle-instantclient-sdk
+# Date created: 2005-04-26
+# Whom: nork@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= instantclient
+PORTVERSION= 10.1.0.3
+CATEGORIES= databases
+MASTER_SITES= #http://www.oracle.com/technology/software/tech/oci/instantclient/
+PKGNAMEPREFIX= linux-oracle-
+PKGNAMESUFFIX= -sdk
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-linux32-${PORTVERSION}
+DIST_SUBDIR= oracle
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= Oracle 10 InstantClient SDK. Works with Oracle RDBMS 8.1.2+
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/oracle/${PORTVERSION}/client/lib/libocci.so.10.1:${.CURDIR}/../linux-oracle-instantclient-basic
+
+ONLY_FOR_ARCHS= i386
+# Couldn't test for IA64, so commented it out
+# ONLY_FOR_ARCHS+= ia64
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+
+RESTRICTED= Packaging prohibited by Oracle license
+
+USE_ZIP= yes
+USE_LINUX_PREFIX= yes
+
+INCS_LIST= nzerror.h \
+ nzt.h \
+ occi.h \
+ occiAQ.h \
+ occiCommon.h \
+ occiControl.h \
+ occiData.h \
+ occiObjects.h \
+ oci.h \
+ oci1.h \
+ oci8dp.h \
+ ociap.h \
+ ociapr.h \
+ ocidef.h \
+ ocidem.h \
+ ocidfn.h \
+ ociextp.h \
+ ocikpr.h \
+ ocixmldb.h \
+ odci.h \
+ oratypes.h \
+ ori.h \
+ orid.h \
+ orl.h \
+ oro.h \
+ ort.h \
+ xa.h
+
+DEMO_LIST= cdemo81.c \
+ demo.mk \
+ occidemo.sql \
+ occidemod.sql \
+ occidml.cpp
+
+WRKSRC= ${WRKDIR}/instantclient10_1/sdk
+
+INSTLIBSDIR= ${PREFIX}/usr/lib/oracle/${PORTVERSION}/client/lib
+INSTINCSDIR= ${PREFIX}/usr/include/oracle/${PORTVERSION}/client
+INSTDEMODIR= ${PREFIX}/usr/share/oracle/${PORTVERSION}/client
+
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
+ECHO_MSG= ${PRINTF} %b
+
+IGNORE+= \n\n-=< MARKED AS IGNORED: >=-\n
+IGNORE+= \n
+IGNORE+= Due to Oracle license restrictions, you must fetch the source \n
+IGNORE+= distribution manually. Please access \n
+IGNORE+= http://www.oracle.com/technology/software/tech/oci/instantclient/index.html \n
+IGNORE+= with a web browser and follow the link for the \n
+IGNORE+= \"${DISTFILES}\". \n
+IGNORE+= You will be required to register and log in, \n
+IGNORE+= but you can create an account on that page. \n
+IGNORE+= After registration and accepting the Oracle License, \n
+IGNORE+= download the distribution file, \n ${DISTFILES}, \n
+IGNORE+= into ${DISTDIR}/${DIST_SUBDIR}/ \n
+IGNORE+= and then restart this installation\n\n
+.endif
+
+do-install:
+ ${MKDIR} -m 0755 ${INSTINCSDIR} ${INSTDEMODIR}
+ ${LN} -s libclntsh.so.10.1 ${INSTLIBSDIR}/libclntsh.so
+ ${LN} -s libocci.so.10.1 ${INSTLIBSDIR}/libocci.so
+.for i in ${INCS_LIST}
+ ${INSTALL_DATA} ${WRKSRC}/include/${i} ${INSTINCSDIR}/${i}
+.endfor
+.for i in ${DEMO_LIST}
+ ${INSTALL_DATA} ${WRKSRC}/demo/${i} ${INSTDEMODIR}/${i}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/databases/linux-oracle-instantclient-sdk/distinfo b/databases/linux-oracle-instantclient-sdk/distinfo
new file mode 100644
index 000000000000..f804e868341c
--- /dev/null
+++ b/databases/linux-oracle-instantclient-sdk/distinfo
@@ -0,0 +1,2 @@
+MD5 (oracle/instantclient-sdk-linux32-10.1.0.3.zip) = 6efd6146c87dc7f10459d2a3423fca28
+SIZE (oracle/instantclient-sdk-linux32-10.1.0.3.zip) = 293949
diff --git a/databases/linux-oracle-instantclient-sdk/pkg-descr b/databases/linux-oracle-instantclient-sdk/pkg-descr
new file mode 100644
index 000000000000..1575c75cb9e5
--- /dev/null
+++ b/databases/linux-oracle-instantclient-sdk/pkg-descr
@@ -0,0 +1,9 @@
+Oracle instant client - Software Development Kit distribution
+
+Instant Client allows you to run your applications without installing
+the standard Oracle client or having an ORACLE_HOME. OCI, OCCI, ODBC,
+and JDBC applications work without modification, while using
+significantly less disk space than before. Even SQL*Plus can be used
+with Instant Client. No recompile, no hassle.
+
+WWW: http://www.oracle.com/technology/tech/oci/instantclient/instantclient.html
diff --git a/databases/linux-oracle-instantclient-sdk/pkg-plist b/databases/linux-oracle-instantclient-sdk/pkg-plist
new file mode 100644
index 000000000000..a9681bc6f211
--- /dev/null
+++ b/databases/linux-oracle-instantclient-sdk/pkg-plist
@@ -0,0 +1,42 @@
+usr/lib/oracle/%%PORTVERSION%%/client/lib/libclntsh.so
+usr/lib/oracle/%%PORTVERSION%%/client/lib/libocci.so
+usr/share/oracle/%%PORTVERSION%%/client/cdemo81.c
+usr/share/oracle/%%PORTVERSION%%/client/demo.mk
+usr/share/oracle/%%PORTVERSION%%/client/occidemo.sql
+usr/share/oracle/%%PORTVERSION%%/client/occidemod.sql
+usr/share/oracle/%%PORTVERSION%%/client/occidml.cpp
+usr/include/oracle/%%PORTVERSION%%/client/nzerror.h
+usr/include/oracle/%%PORTVERSION%%/client/nzt.h
+usr/include/oracle/%%PORTVERSION%%/client/occi.h
+usr/include/oracle/%%PORTVERSION%%/client/occiAQ.h
+usr/include/oracle/%%PORTVERSION%%/client/occiCommon.h
+usr/include/oracle/%%PORTVERSION%%/client/occiControl.h
+usr/include/oracle/%%PORTVERSION%%/client/occiData.h
+usr/include/oracle/%%PORTVERSION%%/client/occiObjects.h
+usr/include/oracle/%%PORTVERSION%%/client/oci.h
+usr/include/oracle/%%PORTVERSION%%/client/oci1.h
+usr/include/oracle/%%PORTVERSION%%/client/oci8dp.h
+usr/include/oracle/%%PORTVERSION%%/client/ociap.h
+usr/include/oracle/%%PORTVERSION%%/client/ociapr.h
+usr/include/oracle/%%PORTVERSION%%/client/ocidef.h
+usr/include/oracle/%%PORTVERSION%%/client/ocidem.h
+usr/include/oracle/%%PORTVERSION%%/client/ocidfn.h
+usr/include/oracle/%%PORTVERSION%%/client/ociextp.h
+usr/include/oracle/%%PORTVERSION%%/client/ocikpr.h
+usr/include/oracle/%%PORTVERSION%%/client/ocixmldb.h
+usr/include/oracle/%%PORTVERSION%%/client/odci.h
+usr/include/oracle/%%PORTVERSION%%/client/oratypes.h
+usr/include/oracle/%%PORTVERSION%%/client/ori.h
+usr/include/oracle/%%PORTVERSION%%/client/orid.h
+usr/include/oracle/%%PORTVERSION%%/client/orl.h
+usr/include/oracle/%%PORTVERSION%%/client/oro.h
+usr/include/oracle/%%PORTVERSION%%/client/ort.h
+usr/include/oracle/%%PORTVERSION%%/client/xa.h
+@dirrm usr/include/oracle/%%PORTVERSION%%/client
+@dirrm usr/include/oracle/%%PORTVERSION%%
+@dirrm usr/include/oracle
+@dirrm usr/share/oracle/%%PORTVERSION%%/client
+@dirrm usr/share/oracle/%%PORTVERSION%%
+@dirrm usr/share/oracle
+@unexec rmdir %D/usr/include 2>/dev/null || true
+@unexec rmdir %D/usr/share 2>/dev/null || true