aboutsummaryrefslogtreecommitdiff
path: root/databases/luadbi
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-19 14:50:52 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-19 14:50:52 +0000
commit67971bd0fb8a440f973d12606b0f496ba216d7df (patch)
tree72fd93ae39b43490b34dc8479465e07b453d126e /databases/luadbi
parentf13c234d6c664c916b5c0d0e6f089d8ef0c93d55 (diff)
downloadports-67971bd0fb8a440f973d12606b0f496ba216d7df.tar.gz
ports-67971bd0fb8a440f973d12606b0f496ba216d7df.zip
Improve shebangfix framework
- Support multiple values in *_OLD_CMD, i.e. we can now fix both "/usr/bin/python" and "/usr/bin/env python" at the same time - Default *_OLD_CMD values are now always appended, so you don't need to specify them in individual ports - Add lua support (depends on USES=lua) - Add more default values, such as "/usr/bin/env foo" for python, perl, bash, ruby and lua - Shebangfix now matches whole words, e.g. we will no longer (erroneously) replace "/usr/bin/perl5.005" with "${perl_CMD}5.005" (but "/usr/bin/perl -tt" is still (correctly) replaced with "${perl_CMD} -tt") Note that *_OLD_CMD items containing spaces must now be quoted (e.g. perl_OLD_CMD=/bin/perl /usr/bin/perl "/usr/bin/env perl") Update shebangfix usage according to new rules in many ports: - Remove *_OLD_CMD for patterns now replaced by default - Quote custom *_OLD_CMD which contain spaces Fix shebangfix usage in many ports (irrelevant to infrastructure change): - Remove redundant SHEBANG_LANG (no need to duplicate default langs) - Remove redundant *_CMD (such as python_CMD=${LOCALBASE}/bin/python${PYTHON_VER} when USES=python is present) - Never use *_OLD_CMD in REINPLACE_CMD matchers, these should always look for exact string Approved by: portmgr (bapt) Differential Revision: D3756
Notes
Notes: svn path=/head/; revision=399684
Diffstat (limited to 'databases/luadbi')
-rw-r--r--databases/luadbi/Makefile3
1 files changed, 0 insertions, 3 deletions
diff --git a/databases/luadbi/Makefile b/databases/luadbi/Makefile
index 1d6e788d754e..e6ff4522f8b5 100644
--- a/databases/luadbi/Makefile
+++ b/databases/luadbi/Makefile
@@ -17,9 +17,6 @@ NO_WRKSUBDIR= yes
USES= gmake lua:51 shebangfix
SHEBANG_FILES= DBI.lua
-SHEBANG_LANG= lua
-lua_OLD_CMD= /usr/bin/lua
-lua_CMD= ${LOCALBASE}/bin/${LUA_CMD}
CFLAGS+= -fpic -I${LOCALBASE}/include -I${LUA_INCDIR} -I. \
-I${LOCALBASE}/include/postgresql/server