aboutsummaryrefslogtreecommitdiff
path: root/databases/luasql-mysql
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
commitbeb1c1fe19992999ef068d0dcb07c0d02f4aea71 (patch)
tree464f76d8fe2b9fd7499e26491ee739bfe0a5444e /databases/luasql-mysql
parent496124accdd4d4221bb883770cd6fe27184bfc96 (diff)
downloadports-beb1c1fe19992999ef068d0dcb07c0d02f4aea71.tar.gz
ports-beb1c1fe19992999ef068d0dcb07c0d02f4aea71.zip
USES=lua gained flavors.
Ports using USES=lua:module or lua:flavors will be flavored. A range of supported lua versions can be set using XX-YY (or XX-, or -YY, or simply ZZ) for ports not supporting all lua versions. USES=lua sets LUA_FLAVOR that needs to be used on all dependencies of flavored lua ports, in a similar way as PHP or Python flavors. PR: 245038 Submitted by: andrew tao11 riddles org uk Reviewed by: mat, kevans, russ haley gmail com Approved by: mat (portmgr) Differential Revision: https://reviews.freebsd.org/D16494
Notes
Notes: svn path=/head/; revision=531700
Diffstat (limited to 'databases/luasql-mysql')
-rw-r--r--databases/luasql-mysql/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/databases/luasql-mysql/Makefile b/databases/luasql-mysql/Makefile
index 0ddba7811587..a82fa012f82b 100644
--- a/databases/luasql-mysql/Makefile
+++ b/databases/luasql-mysql/Makefile
@@ -3,8 +3,10 @@
PORTNAME= luasql
PORTVERSION= 2.5.0
+PORTREVISION= 1
CATEGORIES= databases
PKGNAMESUFFIX= -${LUASQL_DRIVER}
+PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
MAINTAINER= mbeis@xs4all.nl
COMMENT= LuaSQL driver
@@ -14,7 +16,7 @@ LICENSE= MIT
USE_GITHUB= yes
GH_ACCOUNT= keplerproject
-USES= lua gmake dos2unix
+USES= lua:module gmake dos2unix
DOS2UNIX_FILES= src/*.c
ALL_TARGET= ${LUASQL_DRIVER}
@@ -30,8 +32,7 @@ MAKE_ARGS= LUA_DIR=${LUA_SUBDIR} \
CFLAGS+= -Wno-return-type
-PLIST_SUB= LUA_MIDLIBDIR=${LUA_MODLIBDIR} \
- LUASQL_DRIVER=${LUASQL_DRIVER}
+PLIST_SUB= LUASQL_DRIVER=${LUASQL_DRIVER}
.if ${LUASQL_DRIVER} == "mysql"
COMMENT= Lua interface to MySQL