aboutsummaryrefslogtreecommitdiff
path: root/databases/memcached
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-12-04 14:28:22 +0000
committerSteve Wills <swills@FreeBSD.org>2016-12-04 14:28:22 +0000
commit6f4fd1a2853d1026e7ec0aa662bb399217036e30 (patch)
tree96cebd4c868732546b9ab3439d301557db21ec9c /databases/memcached
parentdb59ad46c9e728024f86abd3c6fcd8500e903b73 (diff)
downloadports-6f4fd1a2853d1026e7ec0aa662bb399217036e30.tar.gz
ports-6f4fd1a2853d1026e7ec0aa662bb399217036e30.zip
databases/memcached: fix and enable DTrace option
Notes
Notes: svn path=/head/; revision=427791
Diffstat (limited to 'databases/memcached')
-rw-r--r--databases/memcached/Makefile15
-rw-r--r--databases/memcached/files/patch-configure.ac14
2 files changed, 25 insertions, 4 deletions
diff --git a/databases/memcached/Makefile b/databases/memcached/Makefile
index a019f7bdeb4d..abc84e170e26 100644
--- a/databases/memcached/Makefile
+++ b/databases/memcached/Makefile
@@ -3,6 +3,7 @@
PORTNAME= memcached
PORTVERSION= 1.4.33
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://www.memcached.org/files/ \
GENTOO
@@ -19,7 +20,16 @@ CONFLICTS= memcached-1.2*
# Dtrace option disabled until it is fixed upstream
OPTIONS_DEFINE= SASL DOCS DTRACE
-OPTIONS_DEFAULT= SASL
+OPTIONS_DEFAULT= SASL DTRACE
+
+.if !exists(/usr/sbin/dtrace)
+OPTIONS_EXCLUDE+= DTRACE
+.endif
+
+OPTIONS_EXCLUDE_FreeBSD_9+= DTRACE
+OPTIONS_EXCLUDE_FreeBSD_10+= DTRACE
+OPTIONS_EXCLUDE+= ${OPTIONS_EXCLUDE_${OPSYS}_${OSREL:R}}
+OPTIONS_EXCLUDE_i386= DTRACE
DTRACE_DESC= Enable dtrace probes
SASL_DESC= Enable SASL Authentication
@@ -55,8 +65,9 @@ MAKE_JOBS_UNSAFE= yes
CONFIGURE_ARGS+= --enable-64bit
.endif
+# avoid triggering a bug in libdtrace, see illumos issue 6653
.if ${PORT_OPTIONS:MDTRACE}
-BROKEN= DTRACE broken with gcc/clang - reported upstream
+CFLAGS+= -no-integrated-as
.endif
post-install:
diff --git a/databases/memcached/files/patch-configure.ac b/databases/memcached/files/patch-configure.ac
index d4ddb0b76574..8612373f97c3 100644
--- a/databases/memcached/files/patch-configure.ac
+++ b/databases/memcached/files/patch-configure.ac
@@ -1,6 +1,16 @@
---- configure.ac.orig 2015-06-27 18:28:54 UTC
+--- configure.ac.orig 2016-12-04 13:19:07 UTC
+++ configure.ac
-@@ -581,7 +581,7 @@ then
+@@ -137,8 +137,7 @@ if test "x$enable_dtrace" = "xyes"; then
+ if test "x$DTRACE" != "xno"; then
+ AC_DEFINE([ENABLE_DTRACE],1,[Set to nonzero if you want to include DTRACE])
+ build_dtrace=yes
+- # DTrace on MacOSX does not use -G option
+- $DTRACE -G -o conftest.$$ -s memcached_dtrace.d 2>/dev/zero
++ /usr/bin/true
+ if test $? -eq 0
+ then
+ dtrace_instrument_obj=yes
+@@ -594,7 +593,7 @@ then
elif test "$GCC" = "yes"
then
GCC_VERSION=`$CC -dumpversion`