aboutsummaryrefslogtreecommitdiff
path: root/databases/mydumper
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-10 19:50:23 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-10 19:50:23 +0000
commit3b7bd0a1490f574288fc9a02617a19cf238254e0 (patch)
treec05d182f965de6bace293ed87ece71bd45e7c422 /databases/mydumper
parent913e08e52dca0eafb130dc0942c6275a178095ea (diff)
downloadports-3b7bd0a1490f574288fc9a02617a19cf238254e0.tar.gz
ports-3b7bd0a1490f574288fc9a02617a19cf238254e0.zip
Fix problems with missing libs when the linker enforces explicit linking
(a* to d* categories) PR: 192062
Notes
Notes: svn path=/head/; revision=364564
Diffstat (limited to 'databases/mydumper')
-rw-r--r--databases/mydumper/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/databases/mydumper/Makefile b/databases/mydumper/Makefile
index 37e2d3e2cbfc..a5f190fb8375 100644
--- a/databases/mydumper/Makefile
+++ b/databases/mydumper/Makefile
@@ -20,7 +20,9 @@ USES= cmake pkgconfig
PLIST_FILES= sbin/mydumper sbin/myloader
post-patch:
- @${REINPLACE_CMD} -e 's|-Werror||' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} \
+ -e '/link_libraries(mydumper/s/)$$/ -lm)/' \
+ -e 's|-Werror||' ${WRKSRC}/CMakeLists.txt
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mydumper ${WRKSRC}/myloader ${STAGEDIR}${PREFIX}/sbin/