aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql-connector-c++
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-11-02 13:32:34 +0000
committerRene Ladan <rene@FreeBSD.org>2018-11-02 13:32:34 +0000
commit8a502cb2d43b4059a5678ee4539ca03603104107 (patch)
tree2c2c3d0def8d9d1ad349013f7b532f0065f57789 /databases/mysql-connector-c++
parentf60d4bacdc58ec061406d72cace1ac1266952e39 (diff)
downloadports-8a502cb2d43b4059a5678ee4539ca03603104107.tar.gz
ports-8a502cb2d43b4059a5678ee4539ca03603104107.zip
Remove compatibility code for FreeBSD < 11.2 from all ports.
Simplify some ports where DragonFlyBSD no longer needs to be special-cased. Submitted by: rene Reviewed by: bapt, jbeich Differential Revision: https://reviews.freebsd.org/D17724
Notes
Notes: svn path=/head/; revision=483807
Diffstat (limited to 'databases/mysql-connector-c++')
-rw-r--r--databases/mysql-connector-c++/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/databases/mysql-connector-c++/Makefile b/databases/mysql-connector-c++/Makefile
index 9e1ca96aed17..f07b287c57be 100644
--- a/databases/mysql-connector-c++/Makefile
+++ b/databases/mysql-connector-c++/Makefile
@@ -17,19 +17,13 @@ LIB_DEPENDS= libboost_regex.so:devel/boost-libs
USES= cmake:outsource compiler:c++11-lang mysql ssl
USE_LDCONFIG= yes
-CMAKE_ARGS= -DDOC_DESTINATION="${DOCSDIR}"
+CMAKE_ARGS= -DDOC_DESTINATION="${DOCSDIR}" -DCMAKE_ENABLE_C++11=ON
PLIST_SUB= PORTVERSION=${PORTVERSION}
PORTDOCS= *
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1100000
-CMAKE_ARGS+=-DCMAKE_ENABLE_C++11=ON
-.endif
-
post-install:
@${RM} ${STAGEDIR}${DOCSDIR}/INSTALL \
${STAGEDIR}${DOCSDIR}/COPYING
@@ -67,4 +61,4 @@ do-test:
test/unit/classes/statement )
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>