aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql-connector-c++
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-04 09:28:11 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-04 09:28:11 +0000
commita49192f9f96a34f62f0726cd893d7205f2667541 (patch)
treef527570d4bb193227438469b949ebde517871680 /databases/mysql-connector-c++
parent9bed6d1a51924ce30f66e9423cea3bdd1d988d39 (diff)
downloadports-a49192f9f96a34f62f0726cd893d7205f2667541.tar.gz
ports-a49192f9f96a34f62f0726cd893d7205f2667541.zip
- STAGE-clean
Notes
Notes: svn path=/head/; revision=342491
Diffstat (limited to 'databases/mysql-connector-c++')
-rw-r--r--databases/mysql-connector-c++/Makefile3
-rw-r--r--databases/mysql-connector-c++/files/patch-CMakeLists.txt30
2 files changed, 27 insertions, 6 deletions
diff --git a/databases/mysql-connector-c++/Makefile b/databases/mysql-connector-c++/Makefile
index 102ee4e34b03..2241e4f7da5d 100644
--- a/databases/mysql-connector-c++/Makefile
+++ b/databases/mysql-connector-c++/Makefile
@@ -15,8 +15,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs
USE_MYSQL= 51+
-USE_LDCONFIG= yes
USES= cmake:outsource
+USE_LDCONFIG= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
@@ -52,5 +52,4 @@ regression-test: build
test/unit/classes/statement )
.endif
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/databases/mysql-connector-c++/files/patch-CMakeLists.txt b/databases/mysql-connector-c++/files/patch-CMakeLists.txt
index 037d047e0aa0..4990409a19aa 100644
--- a/databases/mysql-connector-c++/files/patch-CMakeLists.txt
+++ b/databases/mysql-connector-c++/files/patch-CMakeLists.txt
@@ -1,7 +1,29 @@
---- CMakeLists.txt.orig 2012-08-09 10:44:22.000000000 +0200
-+++ CMakeLists.txt 2012-08-09 10:46:37.000000000 +0200
-@@ -252,14 +252,6 @@
- SET( LICENSE_FILENAME "${CPACK_RESOURCE_FILE_LICENSE}")")
+--- CMakeLists.txt.orig 2013-03-25 10:45:20.000000000 +0100
++++ CMakeLists.txt 2014-01-31 14:35:27.000000000 +0100
+@@ -38,7 +38,7 @@
+
+ if(COMMAND cmake_policy AND POLICY CMP0015)
+ cmake_policy(SET CMP0015 NEW)
+-endif(COMMAND cmake_policy)
++endif(COMMAND cmake_policy AND POLICY CMP0015)
+
+ #-----------------
+ # CPPFLAGS, CXXFLAGS and LDFLAGS from the environment
+@@ -221,7 +221,7 @@
+ software free of charge under the GNU General Public License
+ (http://www.gnu.org/licenses/). You can also purchase commercial MySQL
+ licenses from ${CPACK_PACKAGE_VENDOR} if you do not wish to be
+-bound by the terms of the GPL. See the chapter "Licensing and Support"
++bound by the terms of the GPL. See the chapter \"Licensing and Support\"
+ in the manual for further info.")
+
+ IF(EXISTS "${CMAKE_SOURCE_DIR}/COPYING")
+@@ -249,17 +249,9 @@
+
+ IF(WIN32)
+ FILE(WRITE "${CMAKE_SOURCE_DIR}/win/config.cmake" "SET(CONNECTOR_PRODUCT_VERSION ${MYSQLCPPCONN_VERSION})
+-SET( LICENSE_FILENAME "${CPACK_RESOURCE_FILE_LICENSE}")")
++SET( LICENSE_FILENAME ${CPACK_RESOURCE_FILE_LICENSE})")
ENDIF(WIN32)
-INSTALL(FILES