aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql-connector-c++
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2016-01-24 09:08:14 +0000
committerMikhail Teterin <mi@FreeBSD.org>2016-01-24 09:08:14 +0000
commita80b1131fe12eaf286e938a5321f5fc642eae6e2 (patch)
tree5a7ecd9ddcb502a3dfe2a6ff03ce07cf46c840f0 /databases/mysql-connector-c++
parenta2ba5b2b9c9744f873a1262d9766ca34ea887836 (diff)
Upgrade from 1.1.6 to 1.1.7. The changes are listed as:
GA 1.1.7 - - Add JSON support - Allow building without server flags (Bug#21391025) - Correct relative() not seeking after changing position.(Bug#21152054) The first item is only available if the mysql-client is recent enough (version 5.7). For older client-libraries the new patch is required.
Notes
Notes: svn path=/head/; revision=407091
Diffstat (limited to 'databases/mysql-connector-c++')
-rw-r--r--databases/mysql-connector-c++/Makefile2
-rw-r--r--databases/mysql-connector-c++/distinfo4
-rw-r--r--databases/mysql-connector-c++/files/patch-CMakeLists.txt17
-rw-r--r--databases/mysql-connector-c++/files/patch-optional-json36
4 files changed, 39 insertions, 20 deletions
diff --git a/databases/mysql-connector-c++/Makefile b/databases/mysql-connector-c++/Makefile
index f074d9d44af0..4f49244d8ff5 100644
--- a/databases/mysql-connector-c++/Makefile
+++ b/databases/mysql-connector-c++/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mysql-connector-c++
-PORTVERSION= 1.1.6
+PORTVERSION= 1.1.7
CATEGORIES= databases
MASTER_SITES= MYSQL/Connector-C++
diff --git a/databases/mysql-connector-c++/distinfo b/databases/mysql-connector-c++/distinfo
index de8d28b9ec5f..f77771f33b53 100644
--- a/databases/mysql-connector-c++/distinfo
+++ b/databases/mysql-connector-c++/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mysql-connector-c++-1.1.6.tar.gz) = ad710b3900cae3be94656825aa70319cf7a96e1ad46bf93e07275f3606f69447
-SIZE (mysql-connector-c++-1.1.6.tar.gz) = 522236
+SHA256 (mysql-connector-c++-1.1.7.tar.gz) = 5b353fbcd26f607a2a0987ce78a4b811f8971813d46b0f4ae6fa07887e9fc763
+SIZE (mysql-connector-c++-1.1.7.tar.gz) = 518469
diff --git a/databases/mysql-connector-c++/files/patch-CMakeLists.txt b/databases/mysql-connector-c++/files/patch-CMakeLists.txt
deleted file mode 100644
index 7c36e8acfea5..000000000000
--- a/databases/mysql-connector-c++/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,17 +0,0 @@
---- CMakeLists.txt.orig 2015-06-04 12:58:30 UTC
-+++ CMakeLists.txt
-@@ -305,14 +305,6 @@ IF(RPM_LAYOUT)
- SET(DOC_DESTINATION "share/doc/${CPACK_PACKAGE_NAME}-${MYSQLCPPCONN_VERSION}")
- ENDIF()
-
--INSTALL(FILES
-- ${CPACK_RESOURCE_FILE_README}
-- ${CPACK_RESOURCE_FILE_INSTALL}
-- ${CPACK_RESOURCE_FILE_LICENSE}
-- "${CMAKE_SOURCE_DIR}/Licenses_for_Third-Party_Components.txt"
-- "${CMAKE_SOURCE_DIR}/ANNOUNCEMENT"
-- DESTINATION ${DOC_DESTINATION} OPTIONAL)
--
- SET(COMMON_IGNORE_FILES
- "/CMakeFiles/"
- "/Testing/"
diff --git a/databases/mysql-connector-c++/files/patch-optional-json b/databases/mysql-connector-c++/files/patch-optional-json
new file mode 100644
index 000000000000..dea4b21fb0dc
--- /dev/null
+++ b/databases/mysql-connector-c++/files/patch-optional-json
@@ -0,0 +1,36 @@
+The newly-added JSON-support may not be available in the older
+version of MySQL client-library against which this connector may
+be building. Fortunately, that's easy to detect at compile time...
+
+ -mi
+
+--- driver/mysql_resultbind.cpp 2016-01-12 13:42:38.000000000 -0500
++++ driver/mysql_resultbind.cpp 2016-01-24 03:58:18.451886000 -0500
+@@ -87,5 +87,7 @@
+ case MYSQL_TYPE_STRING:
+ case MYSQL_TYPE_VAR_STRING:
++#ifdef MYSQL_TYPE_JSON
+ case MYSQL_TYPE_JSON:
++#endif
+ return st_buffer_size_type(new char[field->max_length + 1], field->max_length + 1, field->type);
+
+--- driver/mysql_util.cpp 2016-01-12 13:42:38.000000000 -0500
++++ driver/mysql_util.cpp 2016-01-24 04:01:04.499990000 -0500
+@@ -432,6 +432,8 @@
+ case MYSQL_TYPE_GEOMETRY:
+ return sql::DataType::GEOMETRY;
++#ifdef MYSQL_TYPE_JSON
+ case MYSQL_TYPE_JSON:
+ return sql::DataType::JSON;
++#endif
+ default:
+ return sql::DataType::UNKNOWN;
+@@ -646,6 +648,8 @@
+ case MYSQL_TYPE_GEOMETRY:
+ return "GEOMETRY";
++#ifdef MYSQL_TYPE_JSON
+ case MYSQL_TYPE_JSON:
+ return "JSON";
++#endif
+ default:
+ return "UNKNOWN";