aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql-connector-c++
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-25 16:17:31 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-25 16:17:31 +0000
commitd78beb132cdff1572d8b545be1fb09eea396d6ae (patch)
tree3ae246ccbda59847628903cdf71a3645fe2d5a86 /databases/mysql-connector-c++
parent4d32bbcef6444fe1625b9b0a62da9c7aceadd457 (diff)
downloadports-d78beb132cdff1572d8b545be1fb09eea396d6ae.tar.gz
ports-d78beb132cdff1572d8b545be1fb09eea396d6ae.zip
Move MySQL support from bsd.databases.mk to Uses/mysql.mk.
Also, USE_MYSQL can't happen after bsd.port.pre.mk because it is a USES. PR: 208971 Submitted by: mat Exp-run by: antoine With hat: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D5951
Notes
Notes: svn path=/head/; revision=414019
Diffstat (limited to 'databases/mysql-connector-c++')
-rw-r--r--databases/mysql-connector-c++/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/databases/mysql-connector-c++/Makefile b/databases/mysql-connector-c++/Makefile
index ce6d01a20c1a..f587cf3b5b8f 100644
--- a/databases/mysql-connector-c++/Makefile
+++ b/databases/mysql-connector-c++/Makefile
@@ -15,8 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
-USE_MYSQL= 51+
-USES= cmake:outsource
+USES= cmake:outsource mysql
USE_LDCONFIG= yes
CMAKE_ARGS= -DDOC_DESTINATION="${DOCSDIR}"