aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql-connector-java51
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2019-01-08 20:36:03 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2019-01-08 20:36:03 +0000
commit389333ae5fcad9c8a37758368cc2fdf8b62b9d9b (patch)
tree7d7037ac7b605d665eb6727077bf7ae9092294ab /databases/mysql-connector-java51
parent6a4f1d35b85e28aa635230991610d216c265db1d (diff)
downloadports-389333ae5fcad9c8a37758368cc2fdf8b62b9d9b.tar.gz
ports-389333ae5fcad9c8a37758368cc2fdf8b62b9d9b.zip
Update databases/mysql-connector-java to 8.0.13
This now requires Java 1.8+ Repo-copy the orgiginal port to databases/mysql-connector-java51 to provide continued support for Java 1,6 and 1.7 users. Hook up to the tree. Summary of Changes: https://insidemysql.com/connector-j-8-0-11-the-face-for-your-brand-new-document-oriented-database/ ChangeLogs: https://dev.mysql.com/doc/relnotes/connector-j/8.0/en/
Notes
Notes: svn path=/head/; revision=489740
Diffstat (limited to 'databases/mysql-connector-java51')
-rw-r--r--databases/mysql-connector-java51/Makefile76
-rw-r--r--databases/mysql-connector-java51/distinfo3
-rw-r--r--databases/mysql-connector-java51/pkg-descr13
3 files changed, 92 insertions, 0 deletions
diff --git a/databases/mysql-connector-java51/Makefile b/databases/mysql-connector-java51/Makefile
new file mode 100644
index 000000000000..c403de3f91d0
--- /dev/null
+++ b/databases/mysql-connector-java51/Makefile
@@ -0,0 +1,76 @@
+# Created by: Matthew Seaman
+# $FreeBSD$
+
+PORTNAME= mysql-connector-java
+PORTVERSION= 5.1.47
+CATEGORIES= databases java
+MASTER_SITES= MYSQL/Connector-J
+PKGNAMESUFFIX= 51
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= MySQL Connector/J: JDBC interface for MySQL
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${JAVALIBDIR}/log4j.jar:devel/log4j
+
+# 8.0.x is now the GA release, but drops support for java 1.6 and 1.7
+PORTSCOUT= limit:^5\.1\..*
+
+USES= cpe
+CPE_VENDOR= oracle
+CPE_PRODUCT= mysql_connector_j
+
+CONFLICTS_INSTALL= mysql-connector-java-8*
+
+NO_ARCH= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.6 1.7 1.8
+BUILDDIR= ${WRKDIR}/${DISTNAME}
+APIDOCSDIR= ${STAGEDIR}${DOCSDIR}/javadoc
+SRCDIR= ${WRKDIR}/${DISTNAME}/src
+JAVADOCDIR= ${WRKDIR}/${DISTNAME}/javadoc
+DESTJARFILE= ${PORTNAME}.jar
+EXTRADOCS= CHANGES
+JARFILE= ${DISTNAME}-bin.jar
+JDCLASSPATH= ${SRCDIR}:${CLASSPATH}
+
+PLIST_FILES= ${JAVAJARDIR}/${DESTJARFILE}
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= *
+
+.include <bsd.port.pre.mk>
+
+do-build:
+ @${DO_NADA}
+
+do-build-DOCS-on:
+.if ${JAVA_PORT_VERSION:M1.8.*}
+ @${ECHO_MSG} "NOTE>>> Generating javadoc is broken with JDK 1.8+"
+.else
+ @${MKDIR} ${JAVADOCDIR} && (cd ${SRCDIR}; \
+ ${JAVADOC} -quiet -breakiterator -encoding utf8 \
+ -d ${JAVADOCDIR} -package -classpath ${JDCLASSPATH} \
+ com.mysql.jdbc org.gjt.mm.mysql)
+.endif
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing .jar files..."
+ ${INSTALL_DATA} ${BUILDDIR}/${JARFILE} ${STAGEDIR}${JAVAJARDIR}/${DESTJARFILE}
+ @${ECHO_MSG} " [ DONE ]"
+
+do-install-DOCS-on:
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @for extradoc in ${EXTRADOCS} ; do \
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/$$extradoc ${STAGEDIR}${DOCSDIR} ; \
+ done
+.if ${JAVA_PORT_VERSION:N1.8.*}
+ @${MKDIR} ${STAGEDIR}${APIDOCSDIR}
+ @cd ${JAVADOCDIR} && ${COPYTREE_SHARE} . ${APIDOCSDIR}
+.endif
+ @${ECHO_MSG} " [ DONE ]"
+
+.include <bsd.port.post.mk>
diff --git a/databases/mysql-connector-java51/distinfo b/databases/mysql-connector-java51/distinfo
new file mode 100644
index 000000000000..fd4681e99a02
--- /dev/null
+++ b/databases/mysql-connector-java51/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1535796903
+SHA256 (mysql-connector-java-5.1.47.tar.gz) = 4ae79214b2f1b5fc600fc867a4d27dcfcb467813c38bf3eee87789ba400349c6
+SIZE (mysql-connector-java-5.1.47.tar.gz) = 4452049
diff --git a/databases/mysql-connector-java51/pkg-descr b/databases/mysql-connector-java51/pkg-descr
new file mode 100644
index 000000000000..ed9bd89df272
--- /dev/null
+++ b/databases/mysql-connector-java51/pkg-descr
@@ -0,0 +1,13 @@
+
+MySQL Connector/J is a native Java driver that converts JDBC (Java
+Database Connectivity) calls into the network protocol used by the
+MySQL database. It lets developers working with the Java programming
+language easily build programs and applets that interact with MySQL
+and connect all corporate data, even in a heterogeneous
+environment. MySQL Connector/J is a Type IV JDBC driver and has a
+complete JDBC feature set that supports the capabilities of MySQL.
+
+This port is derived from the original databases/mysql-jdbc-mm port of
+the mm.mysql JDBC connector by dglo@ssec.wisc.edu.
+
+WWW: https://dev.mysql.com/downloads/connector/j/