aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql-editor
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2007-07-03 18:23:40 +0000
committerMikhail Teterin <mi@FreeBSD.org>2007-07-03 18:23:40 +0000
commite63aeff1bb3686e46c6ff761fe0c885b38e3a3dc (patch)
tree6592e341a016e22b5717ca9af9309b7ab078f99a /databases/mysql-editor
parent2dda29fc41faf800ce42705aba4996caf8f8b0e2 (diff)
downloadports-e63aeff1bb3686e46c6ff761fe0c885b38e3a3dc.tar.gz
ports-e63aeff1bb3686e46c6ff761fe0c885b38e3a3dc.zip
Notes
Diffstat (limited to 'databases/mysql-editor')
-rw-r--r--databases/mysql-editor/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/databases/mysql-editor/Makefile b/databases/mysql-editor/Makefile
index a5d70121aeb3..02a4513237fc 100644
--- a/databases/mysql-editor/Makefile
+++ b/databases/mysql-editor/Makefile
@@ -15,7 +15,9 @@ DISTNAME= ${PORTNAME}
MAINTAINER= mi@aldan.algebra.com
COMMENT= CGI scripts in Perl to edit your MySQL tables
-RUN_DEPENDS= ${CGI_BIN}:${PORTSDIR}/${APACHE_PORT}
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${CGI_BIN}:${PORTSDIR}/${APACHE_PORT} \
+ ${BUILD_DEPENDS}
NO_BUILD= True
APACHE_COMPAT= True
@@ -32,14 +34,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/readme.html ${PREFIX}/share/doc/mysql-editor
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>