aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql-udf
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-07-07 06:44:07 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-07-07 06:44:07 +0000
commitfd22400b4ee74522465d262b17f181fb36426131 (patch)
tree4e3999bf93681818583609125dd0faaf05762913 /databases/mysql-udf
parentfff981e77f48dca40425db2d55dbc98dbfb94f3a (diff)
downloadports-fd22400b4ee74522465d262b17f181fb36426131.tar.gz
ports-fd22400b4ee74522465d262b17f181fb36426131.zip
Notes
Diffstat (limited to 'databases/mysql-udf')
-rw-r--r--databases/mysql-udf/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/databases/mysql-udf/Makefile b/databases/mysql-udf/Makefile
index 3ca66fb1ac19..64fe6bb1f90e 100644
--- a/databases/mysql-udf/Makefile
+++ b/databases/mysql-udf/Makefile
@@ -10,9 +10,12 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Set of user-defined functions for the MySQL server
+BROKEN_aarch64= fails to link: can't create dynamic relocation R_AARCH64_ADR_PREL_PG_HI21 against symbol 'compare_doubles(void const*, void const*)' defined in udf_median.o
+
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= mysql
+CFLAGS_amd64+= -fPIC
MODULES= colwidth confidence_higher confidence_lower correlation \
faculty geomean intercept kurtosis longest median noverm \
@@ -22,12 +25,6 @@ MODULES= colwidth confidence_higher confidence_lower correlation \
PLIST_FILES+= lib/mysql/plugin/udf_${MODULE}.so
.endfor
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == amd64
-CFLAGS+= -fPIC
-.endif
-
do-build:
.for MODULE in ${MODULES}
cd ${WRKSRC} && \
@@ -41,4 +38,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/udf_${MODULE}.so ${STAGEDIR}${PREFIX}/lib/mysql/plugin/udf_${MODULE}.so
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>