aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql40-server
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-02-05 15:34:09 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-02-05 15:34:09 +0000
commit52a1683f7552947bd059bf1a42d08f08af794961 (patch)
tree737761fae46cdfa14b3c4498b811f6c40612cd44 /databases/mysql40-server
parent4aa80a5750d09dfd5ff132394c524eebf723b5a9 (diff)
downloadports-52a1683f7552947bd059bf1a42d08f08af794961.tar.gz
ports-52a1683f7552947bd059bf1a42d08f08af794961.zip
Notes
Diffstat (limited to 'databases/mysql40-server')
-rw-r--r--databases/mysql40-server/Makefile27
-rw-r--r--databases/mysql40-server/files/patch-sql::mysqld.cc12
2 files changed, 17 insertions, 22 deletions
diff --git a/databases/mysql40-server/Makefile b/databases/mysql40-server/Makefile
index 783868f9fbdf..2d9589d95207 100644
--- a/databases/mysql40-server/Makefile
+++ b/databases/mysql40-server/Makefile
@@ -39,7 +39,6 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--without-bench \
--without-extra-tools \
--with-libwrap \
- --with-raid \
--with-mysqlfs \
--with-vio \
--with-low-memory \
@@ -102,8 +101,7 @@ pre-fetch:
@${ECHO} " WITH_OPENSSL=yes Enable secure connections."
@${ECHO} " DB_DIR=directory Set alternate directory for database files"
@${ECHO} " (default is /var/db/mysql)."
- @${ECHO} " SKIP_INSTALL_DB=yes Skip database initialization"
- @${ECHO} " (useful for upgrades)."
+ @${ECHO} " OVERWRITE_DB=yes Re-initialize default databases"
@${ECHO} " SKIP_DNS_CHECK=yes Don't run resolveip to do an additional"
@${ECHO} " DNS check before inserting local hostname to"
@${ECHO} " mysql database"
@@ -118,27 +116,12 @@ pre-configure:
@${FALSE}
.endif
-.if exists(${DB_DIR}) && !defined(PACKAGE_BUILDING) && !defined(OVERWRITE_DB) && !defined(SKIP_INSTALL_DB)
-pre-install:
- @${ECHO} "You appear to already have a mysql database directory in ${DB_DIR}."
- @${ECHO} ""
- @${ECHO} "In order to preserve your existing data, you should:"
- @${ECHO} " - dump all your databases"
- @${ECHO} " - kill mysql if it is running"
- @${ECHO} " - delete the ${DB_DIR} directory"
- @${ECHO} " - run 'make install'"
- @${ECHO} " - start up mysql"
- @${ECHO} " - re-create all of your database"
- @${ECHO} " - re-load your data"
- @${ECHO} ""
- @${ECHO} "If you understand the consequences of this upgrade, please re-build this"
- @${ECHO} "port with the environment variable OVERWRITE_DB defined."
- @${FALSE}
-.endif
-
post-install:
.if !defined(PACKAGE_BUILDING)
-.if !defined(SKIP_INSTALL_DB)
+.if exists(${DB_DIR}) && defined(OVERWRITE_DB)
+ @${RM} -r ${DB_DIR}/mysql ${DB_DIR}/test 2>/dev/null || true
+.endif
+.if !exists(${DB_DIR}) || defined(OVERWRITE_DB)
.if defined(SKIP_DNS_CHECK)
${PREFIX}/bin/mysql_install_db --force
.else
diff --git a/databases/mysql40-server/files/patch-sql::mysqld.cc b/databases/mysql40-server/files/patch-sql::mysqld.cc
new file mode 100644
index 000000000000..1d0288494fb5
--- /dev/null
+++ b/databases/mysql40-server/files/patch-sql::mysqld.cc
@@ -0,0 +1,12 @@
+--- sql/mysqld.cc.orig Wed Feb 5 01:55:03 2003
++++ sql/mysqld.cc Wed Feb 5 01:57:06 2003
+@@ -104,7 +104,8 @@
+ int allow_severity = LOG_INFO;
+ int deny_severity = LOG_WARNING;
+
+-#ifdef __STDC__
++#include <osreldate.h>
++#if defined(__STDC__) && __FreeBSD_version < 500000
+ #define my_fromhost(A) fromhost(A)
+ #define my_hosts_access(A) hosts_access(A)
+ #define my_eval_client(A) eval_client(A)