aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql55-server/Makefile
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2018-11-03 21:54:52 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2018-11-03 21:54:52 +0000
commit43f9ba04f1c3123e79f7c644ead66941cec1989d (patch)
tree456c632a88294948d5dc87bc8b304d47a46232a2 /databases/mysql55-server/Makefile
parenta7091cda19d2a6a6f63cd5ec45d541b1feb98743 (diff)
downloadports-43f9ba04f1c3123e79f7c644ead66941cec1989d.tar.gz
ports-43f9ba04f1c3123e79f7c644ead66941cec1989d.zip
databases/mysql55-server: Adapt ${name}_limits to the new resource
limiting mechanics for services Thanks to the recent change to rc.subr(8) it is no longer necessary to define a resource limiting logic in service scripts. limits(1) is now run by default and its configuration is handled via the "${name}_limits" variable. Unfortunately, there is a collision of variable names. The service scripts are broken on FreeBSD version with that new change (>= 12.0). The patch preserves the old behavior on the systems without the rc.subr(8) modification. PR: 227228 Reviewed by: krion Approved by: krion (mentor), maintainer timeout Differential Revision: https://reviews.freebsd.org/D17818
Notes
Notes: svn path=/head/; revision=483912
Diffstat (limited to 'databases/mysql55-server/Makefile')
-rw-r--r--databases/mysql55-server/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/databases/mysql55-server/Makefile b/databases/mysql55-server/Makefile
index d061ea5c21dc..3c6fa424f32e 100644
--- a/databases/mysql55-server/Makefile
+++ b/databases/mysql55-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= mysql
PORTVERSION= 5.5.62
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= databases ipv6
MASTER_SITES= MYSQL/MySQL-5.5
PKGNAMESUFFIX?= 55-server
@@ -50,6 +50,12 @@ SHEBANG_FILES= scripts/*.pl* scripts/*.sh
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200057
+SUB_LIST+= LEGACY_LIMITS="@comment " MODERN_LIMITS=""
+.else
+SUB_LIST+= LEGACY_LIMITS="" MODERN_LIMITS="@comment "
+.endif
+
.if ${PORT_OPTIONS:MSSL}
CMAKE_ARGS+= -DWITH_SSL=bundled
.endif