aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql56-server/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-09-07 11:16:17 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-09-07 11:16:17 +0000
commitf1ba8488afe8864dc67a3720e8ff1ee0cca0175f (patch)
tree74eb1fc7dd372ebadc2e124411ab7c148d23c276 /databases/mysql56-server/Makefile
parent53d279a72a303ebc4af74c0bf68fd6f09bd5d39e (diff)
downloadports-f1ba8488afe8864dc67a3720e8ff1ee0cca0175f.tar.gz
ports-f1ba8488afe8864dc67a3720e8ff1ee0cca0175f.zip
Switch to USES=libedit.
Instead of manually adding both a build- and a run-time dependency on libedit from ports, use USES=libedit instead. Not only does it take care of adding the proper dependency, but it also sets CMAKE_PREFIX_PATH to ${LOCALBASE} to make sure that the version in ports is preferred instead of the one in base. This is a dependency for moving to CMake 3.3.x, as starting with 3.3.0 calls to find_library() will also look in the $PATH environment variable and end up finding libedit from base by default (see bug 202516). PR: 202618 Approved by: maintainer timeout (ale, 14 days)
Notes
Notes: svn path=/head/; revision=396260
Diffstat (limited to 'databases/mysql56-server/Makefile')
-rw-r--r--databases/mysql56-server/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/databases/mysql56-server/Makefile b/databases/mysql56-server/Makefile
index ef67dcb89c0d..f73327394d32 100644
--- a/databases/mysql56-server/Makefile
+++ b/databases/mysql56-server/Makefile
@@ -64,8 +64,7 @@ MMAN1= my_print_defaults.1 myisam_ftdump.1 myisamchk.1 myisamlog.1 myisampack.1
CMAKE_ARGS+= -DWITH_EMBEDDED_SERVER="ON"
.else
-BUILD_DEPENDS+= libedit>=0:${PORTSDIR}/devel/libedit
-RUN_DEPENDS+= libedit>=0:${PORTSDIR}/devel/libedit
+USES+= libedit
.endif
post-patch:
@@ -76,5 +75,5 @@ post-patch:
.if ${ARCH} == "armv6"
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config.h.cmake
.endif
-
+
.include <bsd.port.post.mk>