aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql56-server/Makefile
diff options
context:
space:
mode:
authorMahdi Mokhtari <mmokhi@FreeBSD.org>2018-04-04 20:45:14 +0000
committerMahdi Mokhtari <mmokhi@FreeBSD.org>2018-04-04 20:45:14 +0000
commitf5b82ad2e1c0be226a8de3f9cd38fc6947ff838c (patch)
tree28736dae35973f5e54ae7ac3c7f52f4374e4b62d /databases/mysql56-server/Makefile
parent30f8d6e2ce9541414971f5b5e287cf8f91d36b3f (diff)
downloadports-f5b82ad2e1c0be226a8de3f9cd38fc6947ff838c.tar.gz
ports-f5b82ad2e1c0be226a8de3f9cd38fc6947ff838c.zip
databases/mysql56-server: Adapt ${name}_limits to the new mechanism
Regarding to the changes to rc.subr(8) it is no longer necessary to define a resource limiting logic in service scripts. limits(1) is now run by default and its configuration is handled via the "${name}_limits" variable. This however causes collision of variable names and also is not compatible with the old mechanism. This fixes the rc-script of mysql56 for the bases with both old and new mechanism. PR: 227229 Submitted by: 0mp Reported by: 0mp Sponsored by: Netzkommune GmbH
Notes
Notes: svn path=/head/; revision=466505
Diffstat (limited to 'databases/mysql56-server/Makefile')
-rw-r--r--databases/mysql56-server/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/databases/mysql56-server/Makefile b/databases/mysql56-server/Makefile
index d89ea80afe6b..269d17980294 100644
--- a/databases/mysql56-server/Makefile
+++ b/databases/mysql56-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= mysql
PORTVERSION= 5.6.39
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= databases ipv6
MASTER_SITES= MYSQL/MySQL-5.6
PKGNAMESUFFIX?= 56-server
@@ -133,6 +133,15 @@ FEDERATED_SUB_LIST+= FEDER="--federated"
FEDERATED_SUB_LIST_OFF+= FEDER=""
.endif
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} != FreeBSD || ${OSVERSION} < 1101514 || \
+ ${OSVERSION} >= 1200000 && ${OSVERSION} < 1200057
+SUB_LIST+= LEGACY_LIMITS="" MODERN_LIMITS="@comment "
+.else
+SUB_LIST+= LEGACY_LIMITS="@comment " MODERN_LIMITS=""
+.endif
+
.include <bsd.port.pre.mk>
post-patch: