aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql57-client
diff options
context:
space:
mode:
authorMahdi Mokhtari <mmokhi@FreeBSD.org>2018-04-22 16:24:08 +0000
committerMahdi Mokhtari <mmokhi@FreeBSD.org>2018-04-22 16:24:08 +0000
commit2a7c73522986f4f7ed89416a6855703770751e35 (patch)
treed8e219ad51df70e427d2ddfe5cf0aaefec1322e7 /databases/mysql57-client
parentb8754765fff269037e1badb7b0793bf2dfcfceb1 (diff)
downloadports-2a7c73522986f4f7ed89416a6855703770751e35.tar.gz
ports-2a7c73522986f4f7ed89416a6855703770751e35.zip
databases/mysql57-client: Fix build with 10.x default compiler/linker
The upstream seems merged our local-patches but added a -R flag to its `c++` [actually ld] command. The -R $DIR is like -rpath on 11.x and CURRENT bases but not on 10.x We then use -rpath to make sure it works on all supported bases. Reported by: John W. O'Brien <john@saltant.com> Sponsored by: Netzkommune GmbH
Notes
Notes: svn path=/head/; revision=468035
Diffstat (limited to 'databases/mysql57-client')
-rw-r--r--databases/mysql57-client/Makefile2
-rw-r--r--databases/mysql57-client/files/patch-libmysql_authentication__ldap_CMakeLists.txt11
2 files changed, 12 insertions, 1 deletions
diff --git a/databases/mysql57-client/Makefile b/databases/mysql57-client/Makefile
index a2553e6dc223..75a0e5c3557e 100644
--- a/databases/mysql57-client/Makefile
+++ b/databases/mysql57-client/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mysql
-PORTREVISION= 0
+PORTREVISION= 1
PKGNAMESUFFIX= 57-client
COMMENT= Multithreaded SQL database (client)
diff --git a/databases/mysql57-client/files/patch-libmysql_authentication__ldap_CMakeLists.txt b/databases/mysql57-client/files/patch-libmysql_authentication__ldap_CMakeLists.txt
new file mode 100644
index 000000000000..843885b37cc7
--- /dev/null
+++ b/databases/mysql57-client/files/patch-libmysql_authentication__ldap_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- libmysql/authentication_ldap/CMakeLists.txt.orig 2018-03-04 13:40:40 UTC
++++ libmysql/authentication_ldap/CMakeLists.txt
+@@ -54,7 +54,7 @@ ENDIF()
+ IF (CMAKE_SYSTEM_NAME MATCHES "SunOS")
+ SET(SASL_LIBRARY "sasl")
+ ELSEIF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+- SET(SASL_LIBRARY "-L/usr/local/lib -R/usr/local/lib -lsasl2")
++ SET(SASL_LIBRARY "-L/usr/local/lib -rpath /usr/local/lib -lsasl2")
+ ELSE()
+ SET(SASL_LIBRARY "sasl2")
+ ENDIF ()