aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql57-client
diff options
context:
space:
mode:
authorMahdi Mokhtari <mmokhi@FreeBSD.org>2019-08-05 23:37:31 +0000
committerMahdi Mokhtari <mmokhi@FreeBSD.org>2019-08-05 23:37:31 +0000
commit4b382c759b5620332704d668ecea2dbbaa79cda9 (patch)
tree5db26176ee630a13c7e3474eab83ed35388f0025 /databases/mysql57-client
parenta7b0878922fb37a87b5b52f332dfc23ffa2919ee (diff)
downloadports-4b382c759b5620332704d668ecea2dbbaa79cda9.tar.gz
ports-4b382c759b5620332704d668ecea2dbbaa79cda9.zip
databases/mysq56-{client, server}: Update to latest release 5.7.27
This update includes security fixes on issues that are mentioned on upstream critical patch report. Further info: https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html#AppendixMSQL PR: 239271 Submitted by: Greg Veldman <freebsd@gregv.net> Reported by: Markus Kohlmeyer <rootservice@gmail.com> Sponsored by: Platform.sh
Notes
Notes: svn path=/head/; revision=508220
Diffstat (limited to 'databases/mysql57-client')
-rw-r--r--databases/mysql57-client/Makefile2
-rw-r--r--databases/mysql57-client/files/patch-scripts_CMakeLists.txt22
2 files changed, 12 insertions, 12 deletions
diff --git a/databases/mysql57-client/Makefile b/databases/mysql57-client/Makefile
index 9efc8da80d88..41124fbea7f9 100644
--- a/databases/mysql57-client/Makefile
+++ b/databases/mysql57-client/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mysql
-PORTREVISION= 1
+PORTREVISION= 0
PKGNAMESUFFIX= 57-client
COMMENT= Multithreaded SQL database (client)
diff --git a/databases/mysql57-client/files/patch-scripts_CMakeLists.txt b/databases/mysql57-client/files/patch-scripts_CMakeLists.txt
index 3e59f3170ddd..493e407cbff5 100644
--- a/databases/mysql57-client/files/patch-scripts_CMakeLists.txt
+++ b/databases/mysql57-client/files/patch-scripts_CMakeLists.txt
@@ -1,6 +1,6 @@
---- scripts/CMakeLists.txt.orig 2016-03-28 18:06:12 UTC
-+++ scripts/CMakeLists.txt
-@@ -43,6 +43,7 @@ ELSE()
+--- scripts/CMakeLists.txt.orig 2019-06-10 10:43:20.000000000 -0400
++++ scripts/CMakeLists.txt 2019-08-01 10:59:24.177559000 -0400
+@@ -46,6 +46,7 @@
MESSAGE(FATAL_ERROR "Cannot concatenate files")
ENDIF()
@@ -8,7 +8,7 @@
# Build mysql_fix_privilege_tables.c
ADD_CUSTOM_COMMAND(
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/mysql_fix_privilege_tables_sql.c
-@@ -63,6 +64,7 @@ ADD_CUSTOM_TARGET(GenFixPrivs
+@@ -66,6 +67,7 @@
DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/mysql_fix_privilege_tables_sql.c
${CMAKE_CURRENT_BINARY_DIR}/sql_commands_sys_schema.h
)
@@ -16,7 +16,7 @@
# If we do not have performance schema compiled in then sys will not work,
# so only create an empty sys database with an auto-generated file,
-@@ -143,6 +145,7 @@ IF(NOT WITHOUT_SERVER)
+@@ -146,6 +148,7 @@
)
ENDIF()
@@ -24,7 +24,7 @@
IF(UNIX)
FILE(WRITE ${CMAKE_CURRENT_BINARY_DIR}/make_binary_distribution
"cd ${CMAKE_BINARY_DIR} && '${CMAKE_CPACK_COMMAND}' -G TGZ --config CPackConfig.cmake\n" )
-@@ -150,6 +153,7 @@ IF(UNIX)
+@@ -153,6 +156,7 @@
COMMAND chmod +x ${CMAKE_CURRENT_BINARY_DIR}/make_binary_distribution
)
ENDIF()
@@ -32,16 +32,16 @@
IF(NOT WITHOUT_SERVER)
INSTALL(FILES
-@@ -347,6 +351,8 @@ MACRO(EXTRACT_LINK_LIBRARIES target var)
+@@ -326,6 +330,8 @@
GET_FILENAME_COMPONENT(lib "${lib}" NAME_WE)
STRING(REGEX REPLACE "^lib" "" lib "${lib}")
- SET(${var} "${${var}}-l${lib} " )
+ SET(${var} "${${var}}-l${lib} " )
+ ELSEIF(lib STREQUAL "-pthread")
-+ SET(${var} "${${var}}-pthread " )
++ SET(${var} "${${var}}-pthread " )
ELSE()
- SET(${var} "${${var}}-l${lib} " )
+ SET(${var} "${${var}}-l${lib} " )
ENDIF()
-@@ -430,19 +436,7 @@ ELSE()
+@@ -411,19 +417,7 @@
# On Unix, most of the files end up in the bin directory
SET(mysql_config_COMPONENT COMPONENT Development)