aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql57-server
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2020-04-30 08:15:11 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2020-04-30 08:15:11 +0000
commit10fe9bef59ddddc6d155d5a5b88a0e6cf4a463e2 (patch)
tree9b5ae3ca4280374882fdebe545b7333f53d6e991 /databases/mysql57-server
parentaa9709f8a977bf86fcba09ef2046a094be67b51c (diff)
downloadports-10fe9bef59ddddc6d155d5a5b88a0e6cf4a463e2.tar.gz
ports-10fe9bef59ddddc6d155d5a5b88a0e6cf4a463e2.zip
databases/mysq56-{client, server}: Update to latest release 5.7.30
Bugs Fixed: - InnoDB: The row_upd_clust_rec_by_insert function, which marks a clustered index record as deleted and inserts an updated version of the record into the clustered index, passed an incorrect n_ext value (the total number of external fields) to lower level functions, causing an assertion failure. - InnoDB: An operation performed with the innodb_buffer_pool_evict debug variable set to uncompressed caused an assertion failure. - InnoDB: An add column operation caused an assertion failure. The failure was due to a dangling pointer. - nnoDB: Updating certain InnoDB system variables that take string values raised invalid read errors during Valgrind testing. - InnoDB: An insert statement on a table with a spatial index raised a record type mismatch assertion due to a tuple corruption. - InnoDB: A function that calculates undo log record size could calculate an incorrect length value in the case of a corrupted undo log record, resulting in a malloc failure. Assertion code was added to detect incorrect calculations. - Replication: While an SQL statement was in the process of being rewritten for the binary log so that sensitive information did not appear in plain text, if a SHOW PROCESSLIST statement was used to inspect the query, the query could become corrupted when it was written to the binary log, causing replication to stop. The process of rewriting the query is now kept private, and the query thread is updated only when rewriting is complete. - Replication: When a GRANT or REVOKE statement is only partially executed, an incident event is logged in the binary log, which makes the replication slave's applier thread stop so that the slave can be reconciled manually with the master. Previously, if a failed GRANT or REVOKE statement was the first statement executed in the session, no GTID was applied to the incident event (because the cache manager did not yet exist for the session), causing an error on the replication slave. Also, no incident event was logged in the situation where a GRANT statement created a user but then failed because the privileges had been specified incorrectly, again causing an error on the replication slave. Both these issues have now been fixed. - Replication: When a replication slave has a generated column that the master does not have in that table, with a secondary index on the generated column, the generated expression should be evaluated and the value stored by the storage engine in the secondary index. When row-based binary logging is in use, the replication slave assigns default values to any fields that are not in the master's definition of the table. In the case of a generated column, which does not have a default value, the slave was previously assigning a null or a zero value to the column. This value was then stored by the storage engine in the secondary index, causing both the table and the index to become corrupted. To fix this issue, generated columns in a table on a replication slave are now re-evaluated before the values are sent to the storage engine. - Replication: In the event of an unplanned disconnection of a replication slave from the master, the reference to the master's dump thread might not be removed from the list of registered slaves, in which case statements that accessed the list of slaves would fail. The issue has now been fixed. - Replication: With the settings binlog_format=MIXED, tx_isolation=READ-COMMITTED, and binlog_row_image=FULL, an INSERT ... SELECT query involving a transactional storage engine omitted any columns with a null value from the row image written to the binary log. This happened because when processing INSERT ... SELECT statements, the columns were marked for inserts before the binary logging format was selected. The issue has now been fixed. Full Changelog: https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-30.html MFH: 2020Q2 Security: 21d59ea3-8559-11ea-a5e2-d4c9ef517024 (MySQL - Server) Security: 622b5c47-855b-11ea-a5e2-d4c9ef517024 (MySQL - Client) Sponsored by: Netzkommune GmbH
Notes
Notes: svn path=/head/; revision=533416
Diffstat (limited to 'databases/mysql57-server')
-rw-r--r--databases/mysql57-server/Makefile4
-rw-r--r--databases/mysql57-server/distinfo6
-rw-r--r--databases/mysql57-server/files/patch-cmake_ssl.cmake12
-rw-r--r--databases/mysql57-server/files/patch-cmd-line-utils_libedit_chartype.h11
-rw-r--r--databases/mysql57-server/files/patch-cmd-line-utils_libedit_vi.c20
5 files changed, 11 insertions, 42 deletions
diff --git a/databases/mysql57-server/Makefile b/databases/mysql57-server/Makefile
index 21b29d743e08..0ab4ee203286 100644
--- a/databases/mysql57-server/Makefile
+++ b/databases/mysql57-server/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME?= mysql
-PORTVERSION= 5.7.29
-PORTREVISION= 1
+PORTVERSION= 5.7.30
+PORTREVISION= 0
CATEGORIES= databases
MASTER_SITES= MYSQL/MySQL-5.7
PKGNAMESUFFIX?= 57-server
diff --git a/databases/mysql57-server/distinfo b/databases/mysql57-server/distinfo
index 6b8608d1f113..df4e9fd09573 100644
--- a/databases/mysql57-server/distinfo
+++ b/databases/mysql57-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1579122971
-SHA256 (mysql-boost-5.7.29.tar.gz) = 00f514124de2bad1ba7b380cbbd46e316cae7fc7bc3a5621456cabf352f27978
-SIZE (mysql-boost-5.7.29.tar.gz) = 51417554
+TIMESTAMP = 1588150116
+SHA256 (mysql-boost-5.7.30.tar.gz) = 211fbbb359da651197e1cc419e215f1f3caee8c1adf7491f5f7ed3e8dbcdb8af
+SIZE (mysql-boost-5.7.30.tar.gz) = 51363998
diff --git a/databases/mysql57-server/files/patch-cmake_ssl.cmake b/databases/mysql57-server/files/patch-cmake_ssl.cmake
index f09b1edc31a8..4ac61da59a4f 100644
--- a/databases/mysql57-server/files/patch-cmake_ssl.cmake
+++ b/databases/mysql57-server/files/patch-cmake_ssl.cmake
@@ -1,16 +1,16 @@
--- cmake/ssl.cmake.orig 2019-12-06 10:41:47 UTC
+++ cmake/ssl.cmake
-@@ -189,7 +189,8 @@ MACRO (MYSQL_CHECK_SSL)
- OPENSSL_FIX_VERSION "${OPENSSL_VERSION_NUMBER}"
- )
- ENDIF()
-- IF("${OPENSSL_MAJOR_VERSION}.${OPENSSL_MINOR_VERSION}.${OPENSSL_FIX_VERSION}" VERSION_GREATER "1.1.0")
+@@ -193,7 +193,8 @@ MACRO (MYSQL_CHECK_SSL)
+ )
+ SET(OPENSSL_VERSION ${OPENSSL_VERSION} CACHE INTERNAL "")
+
+- IF("${OPENSSL_VERSION}" VERSION_GREATER "1.1.0")
+ CHECK_SYMBOL_EXISTS(TLS1_3_VERSION "openssl/tls1.h" HAVE_TLS1_3_VERSION)
+ IF(HAVE_TLS1_3_VERSION)
ADD_DEFINITIONS(-DHAVE_TLSv13)
SET(HAVE_TLSv13 1)
IF(SOLARIS)
-@@ -199,7 +200,13 @@ MACRO (MYSQL_CHECK_SSL)
+@@ -203,7 +204,13 @@ MACRO (MYSQL_CHECK_SSL)
IF(OPENSSL_INCLUDE_DIR AND
OPENSSL_LIBRARY AND
CRYPTO_LIBRARY AND
diff --git a/databases/mysql57-server/files/patch-cmd-line-utils_libedit_chartype.h b/databases/mysql57-server/files/patch-cmd-line-utils_libedit_chartype.h
deleted file mode 100644
index 34fbf5a45509..000000000000
--- a/databases/mysql57-server/files/patch-cmd-line-utils_libedit_chartype.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- cmd-line-utils/libedit/chartype.h.orig 2016-03-28 18:06:12 UTC
-+++ cmd-line-utils/libedit/chartype.h
-@@ -49,7 +49,7 @@
- TODO : Verify if FreeBSD & AIX stores ISO 10646 in wchar_t. */
- #if !defined(__NetBSD__) && !defined(__sun) \
- && !(defined(__APPLE__) && defined(__MACH__)) \
-- && !defined(__FreeBSD__) && !defined(_AIX)
-+ && !defined(__FreeBSD__) && !defined(_AIX) && !defined(__DragonFly__)
- #ifndef __STDC_ISO_10646__
- /* In many places it is assumed that the first 127 code points are ASCII
- * compatible, so ensure wchar_t indeed does ISO 10646 and not some other
diff --git a/databases/mysql57-server/files/patch-cmd-line-utils_libedit_vi.c b/databases/mysql57-server/files/patch-cmd-line-utils_libedit_vi.c
deleted file mode 100644
index cb3e255991ab..000000000000
--- a/databases/mysql57-server/files/patch-cmd-line-utils_libedit_vi.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- cmd-line-utils/libedit/vi.c.orig 2016-03-28 18:06:12 UTC
-+++ cmd-line-utils/libedit/vi.c
-@@ -919,7 +919,7 @@ vi_comment_out(EditLine *el, Int c __att
- * NB: posix implies that we should enter insert mode, however
- * this is against historical precedent...
- */
--#if defined(__weak_reference) && !defined(__FreeBSD__)
-+#if defined(__weak_reference) && !defined(__FreeBSD__) && !defined(__DragonFly__)
- __weakref_visible char *my_get_alias_text(const char *)
- __weak_reference(get_alias_text);
- #endif
-@@ -928,7 +928,7 @@ protected el_action_t
- vi_alias(EditLine *el __attribute__((__unused__)),
- Int c __attribute__((__unused__)))
- {
--#if defined(__weak_reference) && !defined(__FreeBSD__)
-+#if defined(__weak_reference) && !defined(__FreeBSD__) && !defined(__DragonFly__)
- char alias_name[3];
- char *alias_text;
-