aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql57-server
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-08-27 06:21:38 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-08-27 06:21:38 +0000
commit43e3b3998183b336d128852bbe316c97d3f25238 (patch)
tree2d89cf488d61afc69a13be8684f2252e39c3b0d1 /databases/mysql57-server
parent0aa71514e20e84b0f47a3fd9ea8ae7f4013efbfd (diff)
downloadports-43e3b3998183b336d128852bbe316c97d3f25238.tar.gz
ports-43e3b3998183b336d128852bbe316c97d3f25238.zip
databases/mysql57-server: fix build on current (temporary fix)
- add temporary work around to use llvm from ports on recent currents
Notes
Notes: svn path=/head/; revision=546322
Diffstat (limited to 'databases/mysql57-server')
-rw-r--r--databases/mysql57-server/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/databases/mysql57-server/Makefile b/databases/mysql57-server/Makefile
index 2c7ad8d2b837..dfc094fd8961 100644
--- a/databases/mysql57-server/Makefile
+++ b/databases/mysql57-server/Makefile
@@ -162,6 +162,17 @@ CMAKE_ARGS+= -DWITH_SSL=${OPENSSLBASE}
CXXFLAGS+= -fpermissive
.endif
+# mysql57-server fails to compile with llvm11, which was imported to current in r364284
+# without a version increase (1300109 = r364274).
+# Until a proper fix is provided, simply use llvm from ports, which probably could be
+# a backport of amongst other tings:
+# https://github.com/mysql/mysql-server/commit/08f46b3c00ee70e7ed7825daeb91df2289f80f50
+.if ${CHOSEN_COMPILER_TYPE} == clang && ${OPSYS} == FreeBSD && ${OSVERSION} >= 1300109
+BUILD_DEPENDS+= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
+CC= ${LOCALBASE}/bin/clang${LLVM_DEFAULT}
+CXX= ${LOCALBASE}/bin/clang++${LLVM_DEFAULT}
+.endif
+
post-extract:
@${RM} -rv ${WRKSRC}/sql/sql_hints.yy.cc ${WRKSRC}/sql/sql_hints.yy.h