aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql57-server
diff options
context:
space:
mode:
authorMahdi Mokhtari <mmokhi@FreeBSD.org>2018-04-04 20:57:11 +0000
committerMahdi Mokhtari <mmokhi@FreeBSD.org>2018-04-04 20:57:11 +0000
commitafc37e723e71a17362be8732a82c647f6add779c (patch)
treed556cb5a7c7c6bba775b5c160c68d0c63ee2ae9e /databases/mysql57-server
parent556173ac016ba394dd7bbc8b9c269a9b34931030 (diff)
downloadports-afc37e723e71a17362be8732a82c647f6add779c.tar.gz
ports-afc37e723e71a17362be8732a82c647f6add779c.zip
databases/mysql57-server: Adapt ${name}_limits to the new mechanism
Regarding to the changes to rc.subr(8) it is no longer necessary to define a resource limiting logic in service scripts. limits(1) is now run by default and its configuration is handled via the "${name}_limits" variable. This however causes collision of variable names and also is not compatible with the old mechanism. This fixes the rc-script of mysql57 for the bases with both old and new mechanism. (This is port of the r466505 [and r466506]) PR: 227230 Submitted by: 0mp Reported by: 0mp Differential Revision: Netzkommune GmbH
Notes
Notes: svn path=/head/; revision=466507
Diffstat (limited to 'databases/mysql57-server')
-rw-r--r--databases/mysql57-server/Makefile11
-rw-r--r--databases/mysql57-server/files/mysql-server.in24
2 files changed, 21 insertions, 14 deletions
diff --git a/databases/mysql57-server/Makefile b/databases/mysql57-server/Makefile
index a9399568005a..73703d1d9bfe 100644
--- a/databases/mysql57-server/Makefile
+++ b/databases/mysql57-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= mysql
PORTVERSION= 5.7.21
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= databases ipv6
MASTER_SITES= MYSQL/MySQL-5.7
PKGNAMESUFFIX?= 57-server
@@ -142,6 +142,15 @@ FEDERATED_SUB_LIST_OFF+= FEDER=""
CMAKE_ARGS+= -DWITH_AUTHENTICATION_LDAP=0
.endif
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} != FreeBSD || ${OSVERSION} < 1101514 || \
+ ${OSVERSION} >= 1200000 && ${OSVERSION} < 1200057
+SUB_LIST+= LEGACY_LIMITS="" MODERN_LIMITS="@comment "
+.else
+SUB_LIST+= LEGACY_LIMITS="@comment " MODERN_LIMITS=""
+.endif
+
.include <bsd.port.pre.mk>
.if ${SSL_DEFAULT} == base
diff --git a/databases/mysql57-server/files/mysql-server.in b/databases/mysql57-server/files/mysql-server.in
index d33cd12c2a5c..8370afa2c198 100644
--- a/databases/mysql57-server/files/mysql-server.in
+++ b/databases/mysql57-server/files/mysql-server.in
@@ -11,9 +11,9 @@
# Add the following line to /etc/rc.conf to enable mysql:
# mysql_enable (bool): Set to "NO" by default.
# Set it to "YES" to enable MySQL.
-# mysql_limits (bool): Set to "NO" by default.
-# Set it to yes to run `limits -e -U mysql`
-# just before mysql starts.
+%%LEGACY_LIMITS%%# mysql_limits (bool): Set to "NO" by default.
+%%LEGACY_LIMITS%%# Set it to yes to run `limits -e -U mysql`
+%%LEGACY_LIMITS%%# just before mysql starts.
# mysql_dbdir (str): Default to "%%MY_DBDIR%%"
# Base database directory.
# mysql_confdir (str): Default to "%%ETCDIR%%"
@@ -36,7 +36,7 @@ rcvar=mysql_enable
load_rc_config $name
: ${mysql_enable="NO"}
-: ${mysql_limits="NO"}
+%%LEGACY_LIMITS%%: ${mysql_limits="NO"}
: ${mysql_dbdir="%%MY_DBDIR%%"}
: ${mysql_confdir="%%ETCDIR%%"}
if [ -f "${mysql_confdir}/my.cnf" ]; then
@@ -47,13 +47,10 @@ fi
if [ ! -z "${mysql_optfile}" ]; then
mysql_extra="--defaults-extra-file=${mysql_optfile}"
fi
-if [ "${mysql_limits}" = "NO" ]; then
-mysql_limits=""
-fi
mysql_user="mysql"
-mysql_limits_args="-e -U ${mysql_user}"
+%%LEGACY_LIMITS%%mysql_limits_args="-e -U ${mysql_user}"
: ${hostname:=`/bin/hostname`}
pidfile=${mysql_pidfile:-"${mysql_dbdir}/${hostname}.pid"}
command="/usr/sbin/daemon"
@@ -74,11 +71,12 @@ mysql_prestart()
if [ ! -d "${mysql_dbdir}/mysql/." ]; then
mysql_create_auth_tables || return 1
fi
- if [ -z "$mysql_limits" ] || checkyesno mysql_limits; then
- eval `/usr/bin/limits ${mysql_limits_args}` 2>/dev/null
- else
- return 0
- fi
+%%LEGACY_LIMITS%% if checkyesno mysql_limits; then
+%%LEGACY_LIMITS%% eval `/usr/bin/limits ${mysql_limits_args}` 2>/dev/null
+%%LEGACY_LIMITS%% else
+%%LEGACY_LIMITS%% return 0
+%%LEGACY_LIMITS%% fi
+%%MODERN_LIMITS%% return 0
}
mysql_poststart()