aboutsummaryrefslogtreecommitdiff
path: root/databases/mysqlidxchk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-01 21:44:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-01 21:44:10 +0000
commit746d64e9d109143749bfee13444b5aa34d65ae56 (patch)
treeb62afccf2c9c4c866cb84f4435fe0d203988d96d /databases/mysqlidxchk
parentb79a0bbfeb0883630dd683180969b178ab5236e6 (diff)
Notes
Diffstat (limited to 'databases/mysqlidxchk')
-rw-r--r--databases/mysqlidxchk/Makefile39
-rw-r--r--databases/mysqlidxchk/distinfo3
-rw-r--r--databases/mysqlidxchk/pkg-descr6
3 files changed, 48 insertions, 0 deletions
diff --git a/databases/mysqlidxchk/Makefile b/databases/mysqlidxchk/Makefile
new file mode 100644
index 000000000000..565695e3aa3d
--- /dev/null
+++ b/databases/mysqlidxchk/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mysqlidxchk
+# Date created: 29 April 2009
+# Whom: Andrey Ignatov <rdna@rdna.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysqlidxchk
+PORTVERSION= 1.0
+CATEGORIES= databases
+MASTER_SITES= http://hackmysql.com/scripts/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= rdna@rdna.ru
+COMMENT= Checks MySQL databases/tables for unused indexes
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+
+NO_WRKSUBDIR= yes
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/mysqlidxchk
+PORTDOCS= mysqlidxchkdoc.html mysqlidxchkguide.html
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/mysqlidxchk ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/mysqlidxchk/distinfo b/databases/mysqlidxchk/distinfo
new file mode 100644
index 000000000000..88dac856cf13
--- /dev/null
+++ b/databases/mysqlidxchk/distinfo
@@ -0,0 +1,3 @@
+MD5 (mysqlidxchk-1.0.tgz) = 552f979a1e80d05671f57be6969996a9
+SHA256 (mysqlidxchk-1.0.tgz) = 6c5f6c7f93c2bb68cfdc2a36d63528d16e74989b0f9563f1025a833521561d96
+SIZE (mysqlidxchk-1.0.tgz) = 13683
diff --git a/databases/mysqlidxchk/pkg-descr b/databases/mysqlidxchk/pkg-descr
new file mode 100644
index 000000000000..5d588be93442
--- /dev/null
+++ b/databases/mysqlidxchk/pkg-descr
@@ -0,0 +1,6 @@
+mysqlidxchk (MySQL Index Checker) checks MySQL databases/tables for
+unused indexes. Given one or more slow, general, or "raw" log files,
+mysqlidxchk reports which indexes in the database schema are not used
+by the queries in the log files.
+
+WWW: http://hackmysql.com/mysqlidxchk