aboutsummaryrefslogtreecommitdiff
path: root/databases/mysqltcl/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-18 15:59:29 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-18 15:59:29 +0000
commitb44a3949398804841d8a4e386a5adc112a224ae6 (patch)
tree0c0534817cb372acea493330215db0a47d9fc4c7 /databases/mysqltcl/Makefile
parented4a0d7bcf3e1af33227eb0be33474da400cbb67 (diff)
downloadports-b44a3949398804841d8a4e386a5adc112a224ae6.tar.gz
ports-b44a3949398804841d8a4e386a5adc112a224ae6.zip
- Convert to USES=tcl
- STAGE-clean
Notes
Notes: svn path=/head/; revision=344916
Diffstat (limited to 'databases/mysqltcl/Makefile')
-rw-r--r--databases/mysqltcl/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/databases/mysqltcl/Makefile b/databases/mysqltcl/Makefile
index 1ad1f669c4d2..84d429d0b6e0 100644
--- a/databases/mysqltcl/Makefile
+++ b/databases/mysqltcl/Makefile
@@ -9,12 +9,14 @@ MASTER_SITES= http://www.xdobry.de/mysqltcl/
MAINTAINER= tcltk@FreeBSD.org
COMMENT= TCL module for accessing MySQL databases based on msqltcl
-USES+= tcl
+USES= tcl
USE_LDCONFIG= yes
USE_MYSQL= yes
-USE_DOS2UNIX= generic/mysqltcl.c
-MANN= mysqltcl.n
+PLIST_FILES= lib/${PORTNAME}-${PORTVERSION}/libmysqltcl${PORTVERSION}.so \
+ lib/${PORTNAME}-${PORTVERSION}/pkgIndex.tcl \
+ man/mann/mysqltcl.n.gz
+PLIST_DIRS= lib/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
@@ -23,8 +25,4 @@ CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
--with-mysql-lib=${LOCALBASE}/lib/mysql \
--exec-prefix=${PREFIX}
-PLIST_SUB+= LIB_DIR=${PORTNAME}-${PORTVERSION} \
- LIB_NAME=libmysqltcl${PORTVERSION}.so
-
-NO_STAGE= yes
.include <bsd.port.mk>