aboutsummaryrefslogtreecommitdiff
path: root/databases/ocaml-mysql
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2011-10-14 17:13:06 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2011-10-14 17:13:06 +0000
commit3b21ea8e60e9cb302c69747b4e48e36353441cd4 (patch)
treea22686bb47c869a548e02ae8c4b8d49b378877c8 /databases/ocaml-mysql
parentac16e03cca4904870392db6e72527ad518480d22 (diff)
downloadports-3b21ea8e60e9cb302c69747b4e48e36353441cd4.tar.gz
ports-3b21ea8e60e9cb302c69747b4e48e36353441cd4.zip
Add ocaml-mysql 1.1.0, OCaml bindings to libmysqlclient.
PR: ports/161034 Submitted by: Jyun-Yan You <jyyou@cs.nctu.edu.tw>
Notes
Notes: svn path=/head/; revision=283530
Diffstat (limited to 'databases/ocaml-mysql')
-rw-r--r--databases/ocaml-mysql/Makefile42
-rw-r--r--databases/ocaml-mysql/distinfo2
-rw-r--r--databases/ocaml-mysql/pkg-descr5
3 files changed, 49 insertions, 0 deletions
diff --git a/databases/ocaml-mysql/Makefile b/databases/ocaml-mysql/Makefile
new file mode 100644
index 000000000000..9c7f0a213b15
--- /dev/null
+++ b/databases/ocaml-mysql/Makefile
@@ -0,0 +1,42 @@
+# Ports collection makefile for: ocaml-mysql
+# Date created: 2011-09-25
+# Whom: Jyun-Yan You <jyyou@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysql
+PORTVERSION= 1.1.0
+CATEGORIES= databases
+MASTER_SITES= http://forge.ocamlcore.org/frs/download.php/336/
+PKGNAMEPREFIX= ocaml-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jyyou@cs.nctu.edu.tw
+COMMENT= OCaml bindings to libmysqlclient
+
+USE_GMAKE= yes
+USE_MYSQL= yes
+
+USE_OCAML= yes
+USE_OCAML_FINDLIB= yes
+USE_OCAML_FIND_PLIST= yes
+USE_OCAML_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+
+ALL_TARGET= all opt
+.if !defined(NOPORTDOCS)
+ALL_TARGET+= htdoc
+.endif
+
+PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/mysql/html/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/ocaml-mysql/distinfo b/databases/ocaml-mysql/distinfo
new file mode 100644
index 000000000000..77c212271e43
--- /dev/null
+++ b/databases/ocaml-mysql/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ocaml-mysql-1.1.0.tar.gz) = ec624ab82a15c9f7344845333cb4d9cc49e681e91f2965c05d1e1727aa6b02c1
+SIZE (ocaml-mysql-1.1.0.tar.gz) = 107930
diff --git a/databases/ocaml-mysql/pkg-descr b/databases/ocaml-mysql/pkg-descr
new file mode 100644
index 000000000000..ec8aaff875c5
--- /dev/null
+++ b/databases/ocaml-mysql/pkg-descr
@@ -0,0 +1,5 @@
+ocaml-mysql is a package for OCaml that provides access to MySQL
+databases. It consists of low level functions implemented in C and a
+module MySQL intended for application development.
+
+WWW: http://ocaml-mysql.forge.ocamlcore.org/