aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-AnyEvent-CouchDB/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-03 23:28:08 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-03 23:28:08 +0000
commita2808094053fb1113a47ad84b0ae187797ebb8c9 (patch)
tree23162c38112fcdf9d3054d734d4d321f13ad1aef /databases/p5-AnyEvent-CouchDB/Makefile
parente21b3ca271a3fbe53582b32d81f0f8a8c95bd982 (diff)
downloadports-a2808094053fb1113a47ad84b0ae187797ebb8c9.tar.gz
ports-a2808094053fb1113a47ad84b0ae187797ebb8c9.zip
Notes
Diffstat (limited to 'databases/p5-AnyEvent-CouchDB/Makefile')
-rw-r--r--databases/p5-AnyEvent-CouchDB/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/databases/p5-AnyEvent-CouchDB/Makefile b/databases/p5-AnyEvent-CouchDB/Makefile
new file mode 100644
index 000000000000..028b2468d9b7
--- /dev/null
+++ b/databases/p5-AnyEvent-CouchDB/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-AnyEvent-CouchDB
+# Date created: 2011-09-03
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AnyEvent-CouchDB
+PORTVERSION= 1.27
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A non-blocking CouchDB client based on jquery.couch.js
+
+BUILD_DEPENDS= couchdb>=0.9.0:${PORTSDIR}/databases/couchdb \
+ p5-AnyEvent-HTTP>=2.11:${PORTSDIR}/www/p5-AnyEvent-HTTP \
+ p5-CouchDB-View>=0:${PORTSDIR}/databases/p5-CouchDB-View \
+ p5-Data-Dump-Streamer>=0:${PORTSDIR}/devel/p5-Data-Dump-Streamer \
+ p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class \
+ p5-IO-All>=0:${PORTSDIR}/devel/p5-IO-All \
+ p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-Scope-Guard>=0:${PORTSDIR}/devel/p5-Scope-Guard
+BUILD_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= couchdb-push.1
+MAN3= AnyEvent::CouchDB.3 \
+ AnyEvent::CouchDB::Database.3 \
+ AnyEvent::CouchDB::Exceptions.3 \
+ AnyEvent::CouchDB::Stream.3
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>