aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-Excel
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-09-16 05:43:52 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-09-16 05:43:52 +0000
commit6b470bae86247b8cb79b0dc6e43078df2f84c4ae (patch)
treee1545740f8801646e19c181252cb4c4e39df9ca8 /databases/p5-DBD-Excel
parentb63d72fe5f0a821fa729c344f9b44de714603abc (diff)
downloadports-6b470bae86247b8cb79b0dc6e43078df2f84c4ae.tar.gz
ports-6b470bae86247b8cb79b0dc6e43078df2f84c4ae.zip
Conditionalise dependencies on databases/p5-DBI: for perl
5.005_03 use databases/p5-DBI-137 as newer versions do not support the old perl. Note that for some port, I merely removed the explicit dependency as they already have implicit dependencies via other ports. Approved by: portmgr (marcus)
Notes
Notes: svn path=/head/; revision=89001
Diffstat (limited to 'databases/p5-DBD-Excel')
-rw-r--r--databases/p5-DBD-Excel/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/databases/p5-DBD-Excel/Makefile b/databases/p5-DBD-Excel/Makefile
index 167017a4d3bc..5179aeccaf09 100644
--- a/databases/p5-DBD-Excel/Makefile
+++ b/databases/p5-DBD-Excel/Makefile
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= svenasse@polaris.ca
COMMENT= A class for DBI drivers that acts on Excel files
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/SQL/Statement.pm:${PORTSDIR}/databases/p5-SQL-Statement \
+BUILD_DEPENDS= ${SITE_PERL}/SQL/Statement.pm:${PORTSDIR}/databases/p5-SQL-Statement \
${SITE_PERL}/Spreadsheet/ParseExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-ParseExcel \
${SITE_PERL}/Spreadsheet/WriteExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-WriteExcel
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -34,4 +33,14 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>