aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-MariaDB
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2020-08-29 20:34:32 +0000
committerBernard Spil <brnrd@FreeBSD.org>2020-08-29 20:34:32 +0000
commit2b93a34ca7cb22ccedf3842225cfc579fb6d0842 (patch)
treef6b09140ee18bbbaaef4c55efe522374ef74abfe /databases/p5-DBD-MariaDB
parentea82a2aea77b5cd4bc104a8049c67265254869a8 (diff)
downloadports-2b93a34ca7cb22ccedf3842225cfc579fb6d0842.tar.gz
ports-2b93a34ca7cb22ccedf3842225cfc579fb6d0842.zip
databases/mariadb103-server: Update to 10.3.24
Notes
Notes: svn path=/head/; revision=546948
Diffstat (limited to 'databases/p5-DBD-MariaDB')
-rw-r--r--databases/p5-DBD-MariaDB/Makefile37
-rw-r--r--databases/p5-DBD-MariaDB/distinfo3
-rw-r--r--databases/p5-DBD-MariaDB/pkg-descr8
-rw-r--r--databases/p5-DBD-MariaDB/pkg-plist6
4 files changed, 54 insertions, 0 deletions
diff --git a/databases/p5-DBD-MariaDB/Makefile b/databases/p5-DBD-MariaDB/Makefile
new file mode 100644
index 000000000000..fef4f9a1e833
--- /dev/null
+++ b/databases/p5-DBD-MariaDB/Makefile
@@ -0,0 +1,37 @@
+# Created by: Sergey Skvortsov <skv@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= DBD-MariaDB
+PORTVERSION= 1.21
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:CAPTTOFU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT?= MariaDB driver for the Perl5 Database Interface (DBI)
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ p5-Devel-CheckLib>=1.09:devel/p5-Devel-CheckLib
+RUN_DEPENDS= p5-DBI>=1.08:databases/p5-DBI
+TEST_DEPENDS= p5-Test-Deep>=0:devel/p5-Test-Deep
+
+CONFLICTS_INSTALL?= p5-DBD-mysql*
+
+USES= compiler:c11 mysql perl5
+CONFIGURE_ARGS= ${CONFIGURE_ARGS_${CHOSEN_COMPILER_TYPE}}
+CONFIGURE_ARGS_gcc= --libs="-L${PREFIX}/lib/gcc${GCC_DEFAULT} `mysql_config --libs | ${SED} 's/-pthread //'`"
+USE_PERL5= configure
+
+OPTIONS_DEFINE= SSL
+SSL_RUN_DEPENDS= p5-Crypt-SSLeay>=0:security/p5-Crypt-SSLeay
+SSL_USES= ssl
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/DBD/MariaDB/MariaDB.so
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-MariaDB/distinfo b/databases/p5-DBD-MariaDB/distinfo
new file mode 100644
index 000000000000..3858f5eb9ad0
--- /dev/null
+++ b/databases/p5-DBD-MariaDB/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1590929587
+SHA256 (DBD-MariaDB-1.21.tar.gz) = f5972b337a0d1d4726b2471eb79f23ee0cdd034bf43f4e13f2b5162597271419
+SIZE (DBD-MariaDB-1.21.tar.gz) = 179911
diff --git a/databases/p5-DBD-MariaDB/pkg-descr b/databases/p5-DBD-MariaDB/pkg-descr
new file mode 100644
index 000000000000..30456e32f989
--- /dev/null
+++ b/databases/p5-DBD-MariaDB/pkg-descr
@@ -0,0 +1,8 @@
+DBD::mysql is the Perl5 Database Interface driver for the MySQL
+database. In other words: DBD::mysql is an interface between the Perl
+programming language and the MySQL programming API that comes with the
+MySQL relational database management system. Most functions provided by
+this programming API are supported. Some rarely used functions are
+missing, mainly because noone ever requested them.
+
+WWW: https://metacpan.org/release/DBD-mysql
diff --git a/databases/p5-DBD-MariaDB/pkg-plist b/databases/p5-DBD-MariaDB/pkg-plist
new file mode 100644
index 000000000000..6b805fe56c51
--- /dev/null
+++ b/databases/p5-DBD-MariaDB/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_ARCH%%/DBD/MariaDB.pm
+%%SITE_ARCH%%/DBD/MariaDB.pod
+%%SITE_ARCH%%/DBD/MariaDB/INSTALL.pod
+%%SITE_ARCH%%/auto/DBD/MariaDB/MariaDB.so
+%%PERL5_MAN3%%/DBD::MariaDB.3.gz
+%%PERL5_MAN3%%/DBD::MariaDB::INSTALL.3.gz