aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-Multi
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-07 11:57:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-07 11:57:18 +0000
commit4a74764e7af394f6e89b6fef08eae7f1adbb880e (patch)
treeb3f728f37da7191bbc428308561fbfc0079a23cb /databases/p5-DBD-Multi
parent01c6e9bb9287f8d5736d68dfe5300170ad6f7a65 (diff)
downloadports-4a74764e7af394f6e89b6fef08eae7f1adbb880e.tar.gz
ports-4a74764e7af394f6e89b6fef08eae7f1adbb880e.zip
DBD::Multi - Manage Multiple Data Sources with Failover and Load Balancing
WWW: http://search.cpan.org/dist/DBD-Multi/ PR: ports/114378 Submitted by: Tsung-Han Yeh <snowfly at yuntech.edu.tw>
Notes
Notes: svn path=/head/; revision=195131
Diffstat (limited to 'databases/p5-DBD-Multi')
-rw-r--r--databases/p5-DBD-Multi/Makefile30
-rw-r--r--databases/p5-DBD-Multi/distinfo3
-rw-r--r--databases/p5-DBD-Multi/pkg-descr3
-rw-r--r--databases/p5-DBD-Multi/pkg-plist7
4 files changed, 43 insertions, 0 deletions
diff --git a/databases/p5-DBD-Multi/Makefile b/databases/p5-DBD-Multi/Makefile
new file mode 100644
index 000000000000..6227a80a8755
--- /dev/null
+++ b/databases/p5-DBD-Multi/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-DBD-Multi
+# Date created: 2007-07-07
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBD-Multi
+PORTVERSION= 0.10
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= Manage Multiple Data Sources with Failover and Load Balancing
+
+RUN_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Sys/SigAction.pm:${PORTSDIR}/devel/p5-Sys-SigAction \
+ ${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
+ ${SITE_PERL}/Pod/Simple.pm:${PORTSDIR}/textproc/p5-Pod-Simple \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBD::Multi.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-Multi/distinfo b/databases/p5-DBD-Multi/distinfo
new file mode 100644
index 000000000000..444cfdac0b2a
--- /dev/null
+++ b/databases/p5-DBD-Multi/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBD-Multi-0.10.tar.gz) = 548eebd686f03eb04a633eafe12b75ba
+SHA256 (DBD-Multi-0.10.tar.gz) = 0b02ff16692132b79355623dfbf07b65dc75d24073ba6930b95a11904fd02e5d
+SIZE (DBD-Multi-0.10.tar.gz) = 15636
diff --git a/databases/p5-DBD-Multi/pkg-descr b/databases/p5-DBD-Multi/pkg-descr
new file mode 100644
index 000000000000..104ed906650f
--- /dev/null
+++ b/databases/p5-DBD-Multi/pkg-descr
@@ -0,0 +1,3 @@
+DBD::Multi - Manage Multiple Data Sources with Failover and Load Balancing
+
+WWW: http://search.cpan.org/dist/DBD-Multi/
diff --git a/databases/p5-DBD-Multi/pkg-plist b/databases/p5-DBD-Multi/pkg-plist
new file mode 100644
index 000000000000..c6d07d2bfc5f
--- /dev/null
+++ b/databases/p5-DBD-Multi/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/DBD/Multi.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Multi/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Multi
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%
+@dirrm %%SITE_PERL%%/DBD