aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-PgPP
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-10 12:36:56 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-10 12:36:56 +0000
commitca36f47a34ef92b22a7eda4e8e754eb2575dd910 (patch)
treec65b3f96e4f55df61caeeb0f0c57dccbfc94267e /databases/p5-DBD-PgPP
parent03c91fcad631ad923913219fe498154d22cbaf22 (diff)
downloadports-ca36f47a34ef92b22a7eda4e8e754eb2575dd910.tar.gz
ports-ca36f47a34ef92b22a7eda4e8e754eb2575dd910.zip
Add p5-DBD-PgPP 0.05, Pure Perl PostgreSQL driver for the DBI.
PR: ports/70229 Submitted by: Lubomir Marinov <lubomir_m@abv.bg>
Notes
Notes: svn path=/head/; revision=115822
Diffstat (limited to 'databases/p5-DBD-PgPP')
-rw-r--r--databases/p5-DBD-PgPP/Makefile34
-rw-r--r--databases/p5-DBD-PgPP/distinfo2
-rw-r--r--databases/p5-DBD-PgPP/pkg-descr7
-rw-r--r--databases/p5-DBD-PgPP/pkg-plist6
4 files changed, 49 insertions, 0 deletions
diff --git a/databases/p5-DBD-PgPP/Makefile b/databases/p5-DBD-PgPP/Makefile
new file mode 100644
index 000000000000..961272747281
--- /dev/null
+++ b/databases/p5-DBD-PgPP/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-DBD-PgPP
+# Date created: August 8th 2004
+# Whom: Lubomir Marinov <lubomir_m@abv.bg>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBD-PgPP
+PORTVERSION= 0.05
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lubomir_m@abv.bg
+COMMENT= Pure Perl PostgreSQL driver for the DBI
+
+PERL_CONFIGURE= yes
+
+MAN3= DBD::PgPP.3 DBD::DBD-PgPP.ja.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+post-patch:
+ @${PERL} -i -pe 's/\[:graph:\] /\\x20-\\x7e/g' ${WRKSRC}/PgPP.pm
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-DBD-PgPP/distinfo b/databases/p5-DBD-PgPP/distinfo
new file mode 100644
index 000000000000..4b0509af65eb
--- /dev/null
+++ b/databases/p5-DBD-PgPP/distinfo
@@ -0,0 +1,2 @@
+MD5 (DBD-PgPP-0.05.tar.gz) = 159d54a21eda08ab93fd44f2791cf56f
+SIZE (DBD-PgPP-0.05.tar.gz) = 16807
diff --git a/databases/p5-DBD-PgPP/pkg-descr b/databases/p5-DBD-PgPP/pkg-descr
new file mode 100644
index 000000000000..9ade5a4e9e04
--- /dev/null
+++ b/databases/p5-DBD-PgPP/pkg-descr
@@ -0,0 +1,7 @@
+DBD::PgPP is a Pure Perl client interface for the PostgreSQL database.
+It implements the PostgreSQL client/server network protocol and doesn't
+need an external PostgreSQL client library like "libpq" for it to work.
+Consequently, it allows one to connect to a PostgreSQL server from
+operating systems to which PostgreSQL has not been ported.
+
+WWW: http://search.cpan.org/dist/DBD-PgPP/
diff --git a/databases/p5-DBD-PgPP/pkg-plist b/databases/p5-DBD-PgPP/pkg-plist
new file mode 100644
index 000000000000..91ed9aea0dbf
--- /dev/null
+++ b/databases/p5-DBD-PgPP/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/DBD/PgPP.pm
+%%SITE_PERL%%/DBD/DBD-PgPP.ja.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/PgPP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/PgPP
+@unexec rmdir %D/%%SITE_PERL%%/DBD 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD 2>/dev/null || true