aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-XBase
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-09-19 17:06:01 +0000
committerAde Lovett <ade@FreeBSD.org>2000-09-19 17:06:01 +0000
commite40e2d85f603d4e5695a90f188703d63f55e7258 (patch)
tree43946d80394869c8a20a177bc00c0075d9c4aa98 /databases/p5-DBD-XBase
parentdf901763633404e5aea9ff3e0eeb0502a20898ad (diff)
downloadports-e40e2d85f603d4e5695a90f188703d63f55e7258.tar.gz
ports-e40e2d85f603d4e5695a90f188703d63f55e7258.zip
Add p5-DBD-XBase, providing access to XBase (dBase, Fox*) database files,
namely dbf, dbt, fpt, ndx, ntx, mdx, idx and cdx. PR: 21167 Submitted by: Ilia Chipitsine <ilia@jane.cgu.chel.su>
Notes
Notes: svn path=/head/; revision=32870
Diffstat (limited to 'databases/p5-DBD-XBase')
-rw-r--r--databases/p5-DBD-XBase/Makefile37
-rw-r--r--databases/p5-DBD-XBase/distinfo1
-rw-r--r--databases/p5-DBD-XBase/pkg-comment1
-rw-r--r--databases/p5-DBD-XBase/pkg-descr13
-rw-r--r--databases/p5-DBD-XBase/pkg-plist11
5 files changed, 63 insertions, 0 deletions
diff --git a/databases/p5-DBD-XBase/Makefile b/databases/p5-DBD-XBase/Makefile
new file mode 100644
index 000000000000..a91b2f3570f6
--- /dev/null
+++ b/databases/p5-DBD-XBase/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-DBD-XBase
+# Date created: 10th September 2000
+# Whom: Ilia Chipitsine <ilia@jane.cgu.chel.su>
+#
+# $FreeBSD$
+
+PORTNAME= DBD-XBase
+PORTVERSION= 0.161
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ilia@cgu.chel.su
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+
+USE_PERL5= yes
+
+GZIP= -9
+
+MAN1= dbfdump.1 indexdump.1
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= XBase::FAQ.3 XBase::Memo.3 XBase::Index.3 XBase.3 \
+ DBD::XBase.3 XBase::Base.3
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/dbfdump ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/indexdump ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/blib/man1/dbfdump.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/blib/man1/indexdump.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-XBase/distinfo b/databases/p5-DBD-XBase/distinfo
new file mode 100644
index 000000000000..35756074c285
--- /dev/null
+++ b/databases/p5-DBD-XBase/distinfo
@@ -0,0 +1 @@
+MD5 (DBD-XBase-0.161.tar.gz) = 35b132285b3c319115fe09ff6d4910e8
diff --git a/databases/p5-DBD-XBase/pkg-comment b/databases/p5-DBD-XBase/pkg-comment
new file mode 100644
index 000000000000..6384cd21b79f
--- /dev/null
+++ b/databases/p5-DBD-XBase/pkg-comment
@@ -0,0 +1 @@
+Provides access to XBase (dBase, Fox*) database files through DBI
diff --git a/databases/p5-DBD-XBase/pkg-descr b/databases/p5-DBD-XBase/pkg-descr
new file mode 100644
index 000000000000..a7751b25c32f
--- /dev/null
+++ b/databases/p5-DBD-XBase/pkg-descr
@@ -0,0 +1,13 @@
+Module XBase provides access to XBase (dBase, Fox*) database files,
+namely dbf, dbt, fpt, ndx, ntx, mdx, idx and cdx. It provides native
+Perl interface ($table->get_record, $table->update_record) to read
+and write the tables. The index support is alpha and read only at the
+moment.
+
+Module DBD::XBase is a DBI driver that uses the XBase module
+to work with the data, providing you with DBI compliant processing
+interface and SQL commands ($dbh->prepare("SELECT * FROM TABLE")). As
+an argument to DBI->connect, specify "dbi:XBase:$dir", where $dir is
+the directory with the data files.
+
+Jan Pazdziora, adelton@fi.muni.cz
diff --git a/databases/p5-DBD-XBase/pkg-plist b/databases/p5-DBD-XBase/pkg-plist
new file mode 100644
index 000000000000..2ea9127d6e58
--- /dev/null
+++ b/databases/p5-DBD-XBase/pkg-plist
@@ -0,0 +1,11 @@
+bin/dbfdump
+bin/indexdump
+lib/perl5/site_perl/%%PERL_VER%%/XBase.pm
+lib/perl5/site_perl/%%PERL_VER%%/XBase/Base.pm
+lib/perl5/site_perl/%%PERL_VER%%/XBase/FAQ.pod
+lib/perl5/site_perl/%%PERL_VER%%/XBase/Index.pm
+lib/perl5/site_perl/%%PERL_VER%%/XBase/Memo.pm
+lib/perl5/site_perl/%%PERL_VER%%/XBase/SQL.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XBase/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XBase
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/XBase