aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-cego
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-07-07 14:06:02 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-07-07 14:06:02 +0000
commit515764819e14ac14f856cf97fe1c9d8a80defffe (patch)
treeb8d74f8fbc860e13b6e94246d0f0e25a02306a18 /databases/p5-DBD-cego
parent79a32a3f50d3981fbf115fa4e44f7147732b270c (diff)
downloadports-515764819e14ac14f856cf97fe1c9d8a80defffe.tar.gz
ports-515764819e14ac14f856cf97fe1c9d8a80defffe.zip
Notes
Diffstat (limited to 'databases/p5-DBD-cego')
-rw-r--r--databases/p5-DBD-cego/Makefile28
-rw-r--r--databases/p5-DBD-cego/distinfo3
-rw-r--r--databases/p5-DBD-cego/files/patch-makefile-pl44
-rw-r--r--databases/p5-DBD-cego/pkg-descr5
-rw-r--r--databases/p5-DBD-cego/pkg-plist8
5 files changed, 88 insertions, 0 deletions
diff --git a/databases/p5-DBD-cego/Makefile b/databases/p5-DBD-cego/Makefile
new file mode 100644
index 000000000000..e59bc43b382f
--- /dev/null
+++ b/databases/p5-DBD-cego/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-DBD-cego
+# Date created: Jul 2, 2010
+# Whom: Kurt Jaeger <fbsd-ports@opsec.eu>
+#
+# $FreeBSD$
+
+PORTNAME= DBD-cego
+PORTVERSION= 1.1.9
+CATEGORIES= databases perl5
+MASTER_SITES= http://www.lemke-it.com/
+PKGNAMEPREFIX= p5-
+DISTNAME= DBD-cego-${PORTVERSION}
+
+MAINTAINER= fbsd-ports@opsec.eu
+COMMENT= A Cego DBI driver for Perl 5
+
+BUILD_DEPENDS= p5-DBI>=1.61:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= cego.1:${PORTSDIR}/databases/cego
+
+LICENSE= GPLv2
+WRKSRC= ${WRKDIR}/DBD-cego
+PERL_CONFIGURE= yes
+CC= g++
+
+MAN3= DBD::Cego.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-cego/distinfo b/databases/p5-DBD-cego/distinfo
new file mode 100644
index 000000000000..db13d4599df7
--- /dev/null
+++ b/databases/p5-DBD-cego/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBD-cego-1.1.9.tar.gz) = 4c220989e07557873b7ce3e67420897f
+SHA256 (DBD-cego-1.1.9.tar.gz) = 21a9c28961a9c84716220959c9bde77de3a45344f1cc53e51a732adc43ceda84
+SIZE (DBD-cego-1.1.9.tar.gz) = 23577
diff --git a/databases/p5-DBD-cego/files/patch-makefile-pl b/databases/p5-DBD-cego/files/patch-makefile-pl
new file mode 100644
index 000000000000..239684acb453
--- /dev/null
+++ b/databases/p5-DBD-cego/files/patch-makefile-pl
@@ -0,0 +1,44 @@
+--- Makefile.PL 2010-07-02 21:08:00.000000000 +0200
++++ Makefile.PL-new 2010-07-02 21:19:41.000000000 +0200
+@@ -29,24 +29,16 @@
+ "verbose",
+ ) || die Usage();
+
+-if (! exists $opt->{'prefix'})
+-{
+- print "Missing prefix, use option --prefix\n";
+- die Usage();
+-}
+-
+ use vars qw($loadlibs);
+-$loadlibs= "-L" . $opt->{'prefix'} . " -lBase";
++$loadlibs= " -lBase";
+
+ WriteMakefile(
+ 'NAME' => 'DBD::Cego',
+ 'VERSION_FROM' => 'Cego.pm',
+ 'PREREQ_PM' => {DBI => 1.03},
+ 'OBJECT' => '$(O_FILES)',
+- 'INC' => '-I$(DBI_INSTARCH_DIR) -I' . $opt->{'prefix'} . '/include',
+- 'MYEXTLIB' => $opt->{'prefix'} . "/lib/libcego.a "
+- . $opt->{'prefix'} . "/lib/libXML.a "
+- . $opt->{'prefix'} . "/lib/libBase.a",
++ 'INC' => '-I$(DBI_INSTARCH_DIR) -I/usr/local/include',
++ 'MYEXTLIB' => " -lcego -lXML -lBase ",
+ "CC" => "g++",
+ "LD" => "g++",
+ "XSPROTOARG" => "-noprototypes",
+@@ -58,12 +50,7 @@
+
+ sub Usage {
+ print STDERR <<"USAGE";
+-Usage: perl $0 [options]
+-
+-Possible options are:
+-
+- --prefix=<prefix path> Use <prefix> for setting up the appropriate prefix path
+- to find cego libs and includes
++Usage: perl $0
+
+ USAGE
+ exit 1;
diff --git a/databases/p5-DBD-cego/pkg-descr b/databases/p5-DBD-cego/pkg-descr
new file mode 100644
index 000000000000..ccc0587062f1
--- /dev/null
+++ b/databases/p5-DBD-cego/pkg-descr
@@ -0,0 +1,5 @@
+A DBI driver for the Cego database for Perl 5
+
+Many more details are available at:
+
+WWW: http://www.lemke-it.com/
diff --git a/databases/p5-DBD-cego/pkg-plist b/databases/p5-DBD-cego/pkg-plist
new file mode 100644
index 000000000000..0f8f695cd41d
--- /dev/null
+++ b/databases/p5-DBD-cego/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/DBD/Cego.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Cego/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Cego/Cego.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Cego/Cego.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Cego
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/DBD