aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-cego
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2013-07-30 13:50:28 +0000
committerFrederic Culot <culot@FreeBSD.org>2013-07-30 13:50:28 +0000
commitcd219950d2f6d80f6bfd8c2bbe008998c1416a46 (patch)
tree7b203124486b55de94edf4119d547113ce727684 /databases/p5-DBD-cego
parentae652a99ff2f66d85d24acda5aead492c8681b66 (diff)
downloadports-cd219950d2f6d80f6bfd8c2bbe008998c1416a46.tar.gz
ports-cd219950d2f6d80f6bfd8c2bbe008998c1416a46.zip
- Update to 1.2.6
- Update LICENSE (now GPLv3, was GPLv2) PR: ports/179254 Submitted by: Kurt Jaeger <fbsd-ports@opsec.eu> (maintainer)
Notes
Notes: svn path=/head/; revision=323968
Diffstat (limited to 'databases/p5-DBD-cego')
-rw-r--r--databases/p5-DBD-cego/Makefile13
-rw-r--r--databases/p5-DBD-cego/distinfo4
-rw-r--r--databases/p5-DBD-cego/files/patch-makefile-pl36
3 files changed, 30 insertions, 23 deletions
diff --git a/databases/p5-DBD-cego/Makefile b/databases/p5-DBD-cego/Makefile
index adc5815cdb42..c81ac50234d7 100644
--- a/databases/p5-DBD-cego/Makefile
+++ b/databases/p5-DBD-cego/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= DBD-cego
-PORTVERSION= 1.2.0
+PORTVERSION= 1.2.6
CATEGORIES= databases perl5
MASTER_SITES= http://www.lemke-it.com/
PKGNAMEPREFIX= p5-
@@ -10,12 +10,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= fbsd-ports@opsec.eu
COMMENT= Cego DBI driver for Perl 5
-LICENSE= GPLv2
+LICENSE= GPLv3
-BUILD_DEPENDS= p5-DBI>=1.61:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= p5-DBI>=1.61:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-DBI>=1.628:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= p5-DBI>=1.628:${PORTSDIR}/databases/p5-DBI
LIB_DEPENDS= cego.1:${PORTSDIR}/databases/cego
-MAKE_JOBS_UNSAFE= yes
+
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
PERL_CONFIGURE= yes
CC:= ${CXX}
diff --git a/databases/p5-DBD-cego/distinfo b/databases/p5-DBD-cego/distinfo
index 1d07269a4bdf..a7ea05676cf9 100644
--- a/databases/p5-DBD-cego/distinfo
+++ b/databases/p5-DBD-cego/distinfo
@@ -1,2 +1,2 @@
-SHA256 (DBD-cego-1.2.0.tar.gz) = 37f4cbc997abeb8d089b63ae863e186f38349f04d1045a45c0b414361a7c1436
-SIZE (DBD-cego-1.2.0.tar.gz) = 16433
+SHA256 (DBD-cego-1.2.6.tar.gz) = d944addd62cb3c6bdc853269a7f645f99a7fa255113c7279c81e06313d4b98e9
+SIZE (DBD-cego-1.2.6.tar.gz) = 28192
diff --git a/databases/p5-DBD-cego/files/patch-makefile-pl b/databases/p5-DBD-cego/files/patch-makefile-pl
index 74cff28dda38..38520dc61cdf 100644
--- a/databases/p5-DBD-cego/files/patch-makefile-pl
+++ b/databases/p5-DBD-cego/files/patch-makefile-pl
@@ -1,6 +1,6 @@
---- Makefile.PL.orig 2010-09-17 10:14:49.000000000 +0200
-+++ Makefile.PL 2013-03-29 14:42:20.000000000 +0100
-@@ -25,30 +25,22 @@
+--- Makefile.PL-orig 2013-07-09 09:44:14.000000000 +0200
++++ Makefile.PL 2013-07-09 09:48:24.000000000 +0200
+@@ -28,33 +28,23 @@
Getopt::Long::GetOptions(
$opt,
"help",
@@ -16,29 +16,33 @@
-
-use vars qw($loadlibs);
-$loadlibs= "-L" . $opt->{'prefix'} . " -llfc";
-+# use vars qw($loadlibs);
-+# $loadlibs= "-L/usr/local/lib";
+ my $so = $Config{so};
WriteMakefile(
'NAME' => 'DBD::Cego',
'VERSION_FROM' => 'Cego.pm',
- 'PREREQ_PM' => {DBI => 1.03},
+- 'PREREQ_PM' => {DBI => 1.03},
++ 'PREREQ_PM' => {DBI => 1.628},
'OBJECT' => '$(O_FILES)',
- 'INC' => '-I$(DBI_INSTARCH_DIR) -I' . $opt->{'prefix'} . '/include -I' . $opt->{'prefix'} . '/include',
-- 'MYEXTLIB' => $opt->{'prefix'} . "/lib/libcego.a "
-- . $opt->{'prefix'} . "/lib/liblfcxml.a "
-- . $opt->{'prefix'} . "/lib/liblfc.a",
+- 'MYEXTLIB' => $opt->{'prefix'} . "/lib/libcego.$so* "
+- . $opt->{'prefix'} . "/lib/liblfcxml.$so* "
+- . $opt->{'prefix'} . "/lib/liblfcbase.$so",
- "CC" => "g++",
- "LD" => "g++",
+- "XSPROTOARG" => "-noprototypes",
+- 'OPTIMIZE' => '-O6 -DNDEBUG=1',
+ 'INC' => '-I$(DBI_INSTARCH_DIR) -I/usr/local/include',
-+ 'MYEXTLIB' => '-lcego -llfcxml -llfc',
-+ 'CC' => 'g++',
-+ 'CCFLAGS' => '-O2 -pipe -fno-strict-aliasing -fpermissive',
-+ "LD" => "g++ -L/usr/local/lib",
- "XSPROTOARG" => "-noprototypes",
- 'OPTIMIZE' => '-O6 -DNDEBUG=1',
++ 'MYEXTLIB' => '-lcego -llfcxml -llfcbase',
++ 'CC' => 'g++',
++ 'CCFLAGS' => '-O2 -pipe -fno-strict-aliasing -fpermissive',
++ 'LD' => 'g++ -L/usr/local/lib',
++ 'XSPROTOARG' => '-noprototypes',
++ 'OPTIMIZE' => '-O3 -DNDEBUG=1',
'XSOPT' => '-C++',
-@@ -59,12 +51,6 @@
+ 'TYPEMAPS' => ['perlobject.map' ],
+ 'clean' => { FILES => 'config.h' },
+@@ -63,12 +53,6 @@
sub Usage {
print STDERR <<"USAGE";
Usage: perl $0 [options]