aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-cego
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-30 04:40:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-30 04:40:54 +0000
commitdcce2e294012a74d5663fa718707c8c04ddf3ae4 (patch)
treeb624c7ff0124b622892d548b45bff922bd7477ce /databases/p5-DBD-cego
parent8822ceead24dfbfd61505f75f6156b79af4cfa5d (diff)
downloadports-dcce2e294012a74d5663fa718707c8c04ddf3ae4.tar.gz
ports-dcce2e294012a74d5663fa718707c8c04ddf3ae4.zip
Notes
Diffstat (limited to 'databases/p5-DBD-cego')
-rw-r--r--databases/p5-DBD-cego/Makefile8
-rw-r--r--databases/p5-DBD-cego/files/patch-makefile-pl14
2 files changed, 12 insertions, 10 deletions
diff --git a/databases/p5-DBD-cego/Makefile b/databases/p5-DBD-cego/Makefile
index 433680dbe771..8116fcd3adbd 100644
--- a/databases/p5-DBD-cego/Makefile
+++ b/databases/p5-DBD-cego/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: p5-DBD-cego
-# Date created: Jul 2, 2010
-# Whom: Kurt Jaeger <fbsd-ports@opsec.eu>
-#
+# Created by: Kurt Jaeger <fbsd-ports@opsec.eu>
# $FreeBSD$
PORTNAME= DBD-cego
@@ -24,4 +21,7 @@ CC:= ${CXX}
MAN3= DBD::Cego.3
+post-configure:
+ @${REINPLACE_CMD} -e 's|fno-strict-aliasing|fno-strict-aliasing -fpermissive|g' ${WRKSRC}/Makefile
+
.include <bsd.port.mk>
diff --git a/databases/p5-DBD-cego/files/patch-makefile-pl b/databases/p5-DBD-cego/files/patch-makefile-pl
index 4b8fc262b300..74cff28dda38 100644
--- a/databases/p5-DBD-cego/files/patch-makefile-pl
+++ b/databases/p5-DBD-cego/files/patch-makefile-pl
@@ -1,6 +1,6 @@
---- Makefile.PL 2010-09-17 10:14:49.000000000 +0200
-+++ /tmp/bla/Makefile.PL 2011-04-24 22:00:03.000000000 +0200
-@@ -25,30 +25,21 @@
+--- Makefile.PL.orig 2010-09-17 10:14:49.000000000 +0200
++++ Makefile.PL 2013-03-29 14:42:20.000000000 +0100
+@@ -25,30 +25,22 @@
Getopt::Long::GetOptions(
$opt,
"help",
@@ -28,15 +28,17 @@
- 'MYEXTLIB' => $opt->{'prefix'} . "/lib/libcego.a "
- . $opt->{'prefix'} . "/lib/liblfcxml.a "
- . $opt->{'prefix'} . "/lib/liblfc.a",
+- "CC" => "g++",
+- "LD" => "g++",
+ 'INC' => '-I$(DBI_INSTARCH_DIR) -I/usr/local/include',
+ 'MYEXTLIB' => '-lcego -llfcxml -llfc',
- "CC" => "g++",
-- "LD" => "g++",
++ 'CC' => 'g++',
++ 'CCFLAGS' => '-O2 -pipe -fno-strict-aliasing -fpermissive',
+ "LD" => "g++ -L/usr/local/lib",
"XSPROTOARG" => "-noprototypes",
'OPTIMIZE' => '-O6 -DNDEBUG=1',
'XSOPT' => '-C++',
-@@ -59,12 +50,6 @@
+@@ -59,12 +51,6 @@
sub Usage {
print STDERR <<"USAGE";
Usage: perl $0 [options]