aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Admin-CreateTable
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-11 17:58:15 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-11 17:58:15 +0000
commitf29a48a86278acb5f03b4eba92140f5ac48bf408 (patch)
treec6f2d6564fd16d36bd33b5ab85684ec93cf9117d /databases/p5-DBIx-Admin-CreateTable
parent4169d79ffc988206d68e3b5c60ece8a72a713360 (diff)
downloadports-f29a48a86278acb5f03b4eba92140f5ac48bf408.tar.gz
ports-f29a48a86278acb5f03b4eba92140f5ac48bf408.zip
- Add p5-DBIx-Admin-CreateTable 2.10
DBIx::Admin::CreateTable is a pure Perl module. Database vendors supported: MySQL, Oracle, Postgres, SQLite. Assumptions: - Every table has a primary key - The primary key is a unique, non-null, integer - The primary key is a single column - The primary key column is called 'id' - If a primary key has a corresponding auto-created index, the index is called 't_pkey': This is true for Postgres, where declaring a column as a primary key automatically results in the creation of an associated index for that column. The index is named after the table, not after the column. - If a table 't' (with primary key 'id') has an associated sequence, the sequence is called 't_id_seq': This is true for both Oracle and Postgres, which use sequences to populate primary key columns. The sequences are named after both the table and the column. WWW: http://search.cpan.org/dist/DBIx-Admin-CreateTable/
Notes
Notes: svn path=/head/; revision=347896
Diffstat (limited to 'databases/p5-DBIx-Admin-CreateTable')
-rw-r--r--databases/p5-DBIx-Admin-CreateTable/Makefile24
-rw-r--r--databases/p5-DBIx-Admin-CreateTable/distinfo2
-rw-r--r--databases/p5-DBIx-Admin-CreateTable/pkg-descr19
-rw-r--r--databases/p5-DBIx-Admin-CreateTable/pkg-plist8
4 files changed, 53 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Admin-CreateTable/Makefile b/databases/p5-DBIx-Admin-CreateTable/Makefile
new file mode 100644
index 000000000000..4b0e7186d467
--- /dev/null
+++ b/databases/p5-DBIx-Admin-CreateTable/Makefile
@@ -0,0 +1,24 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= DBIx-Admin-CreateTable
+PORTVERSION= 2.10
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Create and drop tables, primary indexes, and sequences
+
+LICENSE= ART20
+
+BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-Moo>=1.004002:${PORTSDIR}/devel/p5-Moo
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Version>=1.002.003:${PORTSDIR}/devel/p5-Test-Version
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Admin-CreateTable/distinfo b/databases/p5-DBIx-Admin-CreateTable/distinfo
new file mode 100644
index 000000000000..5f32f2815539
--- /dev/null
+++ b/databases/p5-DBIx-Admin-CreateTable/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DBIx-Admin-CreateTable-2.10.tgz) = e9ce9e4581ab7dbfaa57ca36bd5437b9cdf50a51e11df40d9c15bbf095addc24
+SIZE (DBIx-Admin-CreateTable-2.10.tgz) = 12637
diff --git a/databases/p5-DBIx-Admin-CreateTable/pkg-descr b/databases/p5-DBIx-Admin-CreateTable/pkg-descr
new file mode 100644
index 000000000000..40637c5593e9
--- /dev/null
+++ b/databases/p5-DBIx-Admin-CreateTable/pkg-descr
@@ -0,0 +1,19 @@
+DBIx::Admin::CreateTable is a pure Perl module.
+
+Database vendors supported: MySQL, Oracle, Postgres, SQLite.
+
+Assumptions:
+- Every table has a primary key
+- The primary key is a unique, non-null, integer
+- The primary key is a single column
+- The primary key column is called 'id'
+- If a primary key has a corresponding auto-created index, the index is called
+ 't_pkey': This is true for Postgres, where declaring a column as a primary
+ key automatically results in the creation of an associated index for that
+ column. The index is named after the table, not after the column.
+- If a table 't' (with primary key 'id') has an associated sequence, the
+ sequence is called 't_id_seq': This is true for both Oracle and Postgres,
+ which use sequences to populate primary key columns. The sequences are named
+ after both the table and the column.
+
+WWW: http://search.cpan.org/dist/DBIx-Admin-CreateTable/
diff --git a/databases/p5-DBIx-Admin-CreateTable/pkg-plist b/databases/p5-DBIx-Admin-CreateTable/pkg-plist
new file mode 100644
index 000000000000..dcfbb00b6721
--- /dev/null
+++ b/databases/p5-DBIx-Admin-CreateTable/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/DBIx/Admin/CreateTable.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Admin/CreateTable/.packlist
+%%PERL5_MAN3%%/DBIx::Admin::CreateTable.3.gz
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Admin/CreateTable
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Admin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx
+@dirrmtry %%SITE_PERL%%/DBIx/Admin
+@dirrmtry %%SITE_PERL%%/DBIx