aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2009-03-25 10:43:25 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2009-03-25 10:43:25 +0000
commit471eca0026c968daed682855798b1554beca6661 (patch)
treefedf5fcd1ccfb6741d7cbcb79aa24229452fe44a /databases/p5-DBIx-Class-ResultSet-RecursiveUpdate
parent1ddb7e8c83f302a164742e34a95ac5280e17be8c (diff)
downloadports-471eca0026c968daed682855798b1554beca6661.tar.gz
ports-471eca0026c968daed682855798b1554beca6661.zip
Notes
Diffstat (limited to 'databases/p5-DBIx-Class-ResultSet-RecursiveUpdate')
-rw-r--r--databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile29
-rw-r--r--databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/distinfo3
-rw-r--r--databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/pkg-descr11
-rw-r--r--databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/pkg-plist7
4 files changed, 50 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile b/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile
new file mode 100644
index 000000000000..d86af29aafd8
--- /dev/null
+++ b/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: DBIx::Class::ResultSet::RecursiveUpdate
+# Date created: 25 Mar 2009
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Class-ResultSet-RecursiveUpdate
+PORTVERSION= v0.002
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Like update_or_create - but recursive
+
+RUN_DEPENDS= \
+ p5-DBIx-Class>=0.08011:${PORTSDIR}/databases/p5-DBIx-Class \
+ p5-DBIx-Class-IntrospectableM2M>=0:${PORTSDIR}/databases/p5-DBIx-Class-IntrospectableM2M \
+ p5-version>=0:${PORTSDIR}/devel/p5-version \
+ p5-SQL-Translator>=0.08:${PORTSDIR}/databases/p5-SQL-Translator \
+ p5-DateTime>0:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Class::ResultSet::RecursiveUpdate.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/distinfo b/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/distinfo
new file mode 100644
index 000000000000..cb5ab510f63e
--- /dev/null
+++ b/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBIx-Class-ResultSet-RecursiveUpdate-v0.002.tar.gz) = f24a772e098223693737f9a3b5922343
+SHA256 (DBIx-Class-ResultSet-RecursiveUpdate-v0.002.tar.gz) = 0a389d7954256c5c03dba02647a7f57c57117d211aa4fbc543d0f21109ca982e
+SIZE (DBIx-Class-ResultSet-RecursiveUpdate-v0.002.tar.gz) = 12367
diff --git a/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/pkg-descr b/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/pkg-descr
new file mode 100644
index 000000000000..d5c9f8658f3f
--- /dev/null
+++ b/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/pkg-descr
@@ -0,0 +1,11 @@
+It is a base class for ResultSets providing just one method: recur-
+sive_update which works just like update_or_create but can recursively
+update or create data objects composed of multiple rows. All rows need
+to be identified by primary keys - so you need to provide them in the
+update structure (unless they can be deduced from the parent row - for
+example when you have a belongs_to relationship). If not all colums
+comprising the primary key are specified - then a new row will be cre-
+ated, with the expectation that the missing columns will be filled by
+it (as in the case of auto_increment primary keys).
+
+WWW: http://search.cpan.org/dist/DBIx-Class-ResultSet-RecursiveUpdate/
diff --git a/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/pkg-plist b/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/pkg-plist
new file mode 100644
index 000000000000..874f9a525f5f
--- /dev/null
+++ b/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/ResultSet/RecursiveUpdate/.packlist
+%%SITE_PERL%%/DBIx/Class/ResultSet/RecursiveUpdate.pm
+@dirrmtry %%SITE_PERL%%/DBIx/Class/ResultSet
+@dirrmtry %%SITE_PERL%%/DBIx/Class
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/ResultSet/RecursiveUpdate
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/ResultSet
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class