aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Class-Schema-Loader
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2009-09-14 14:58:33 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2009-09-14 14:58:33 +0000
commit8e6efe792c9deddcee4d9ebddeeba183ec89a710 (patch)
treee7a485bcd0ac5d07a79deca7265fb161ae21208d /databases/p5-DBIx-Class-Schema-Loader
parent3e3f4256efabe779b59b2a91319815535faa2991 (diff)
downloadports-8e6efe792c9deddcee4d9ebddeeba183ec89a710.tar.gz
ports-8e6efe792c9deddcee4d9ebddeeba183ec89a710.zip
- Fix commens in generated files.
Obtained from: v0.04999_07 (development version)
Notes
Notes: svn path=/head/; revision=241397
Diffstat (limited to 'databases/p5-DBIx-Class-Schema-Loader')
-rw-r--r--databases/p5-DBIx-Class-Schema-Loader/Makefile4
-rw-r--r--databases/p5-DBIx-Class-Schema-Loader/files/patch-Base.pm21
2 files changed, 25 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Class-Schema-Loader/Makefile b/databases/p5-DBIx-Class-Schema-Loader/Makefile
index 83f649cbef99..52a6515e6071 100644
--- a/databases/p5-DBIx-Class-Schema-Loader/Makefile
+++ b/databases/p5-DBIx-Class-Schema-Loader/Makefile
@@ -7,6 +7,7 @@
PORTNAME= DBIx-Class-Schema-Loader
PORTVERSION= 0.04006
+PORTREVISION= 1
CATEGORIES= databases perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -42,6 +43,9 @@ MAN3= DBIx::Class::Schema::Loader.3 \
post-extract:
@${PERL} -i.bak -ne 'print unless /^\s*(test_requires|auto_install|recommends|configure_requires)/ or /^my/ .. /^}\s*$$/' ${WRKSRC}/Makefile.PL
+post-patch:
+ ${FIND} ${WRKSRC} -name '*.orig' -print0 | ${XARGS} -0 ${RM}
+
OPTIONS= SQLITE "SQLite Support" Off \
MYSQL "MySQL Support" Off \
PG "PostgreSQL Support" Off \
diff --git a/databases/p5-DBIx-Class-Schema-Loader/files/patch-Base.pm b/databases/p5-DBIx-Class-Schema-Loader/files/patch-Base.pm
new file mode 100644
index 000000000000..c439a0dc972d
--- /dev/null
+++ b/databases/p5-DBIx-Class-Schema-Loader/files/patch-Base.pm
@@ -0,0 +1,21 @@
+--- lib/DBIx/Class/Schema/Loader/Base.pm.orig 2009-09-14 23:26:50.599067735 +0900
++++ lib/DBIx/Class/Schema/Loader/Base.pm 2009-09-14 23:28:09.491148344 +0900
+@@ -317,12 +317,12 @@
+ open(my $fh, '<', $real_inc_path)
+ or croak "Failed to open '$real_inc_path' for reading: $!";
+ $self->_ext_stmt($class,
+- qq|# These lines were loaded from '$real_inc_path' found in \@INC.|
+- .q|# They are now part of the custom portion of this file|
+- .q|# for you to hand-edit. If you do not either delete|
+- .q|# this section or remove that file from @INC, this section|
+- .q|# will be repeated redundantly when you re-create this|
+- .q|# file again via Loader!|
++ qq|# These lines were loaded from '$real_inc_path' found in \@INC.\n|
++ .qq|# They are now part of the custom portion of this file\n|
++ .qq|# for you to hand-edit. If you do not either delete\n|
++ .qq|# this section or remove that file from \@INC, this section\n|
++ .qq|# will be repeated redundantly when you re-create this\n|
++ .qq|# file again via Loader!\n|
+ );
+ while(<$fh>) {
+ chomp;