aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Class-Tree
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2011-03-18 01:22:11 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2011-03-18 01:22:11 +0000
commitabb6952193cea42ead402f869bd512b730acb466 (patch)
treed3b7d515eb15c01bb56680fa45ab2abadf444c0e /databases/p5-DBIx-Class-Tree
parent5ae8b2a249c35ec4fb82ab51ab3a344d0a41d80c (diff)
downloadports-abb6952193cea42ead402f869bd512b730acb466.tar.gz
ports-abb6952193cea42ead402f869bd512b730acb466.zip
Notes
Diffstat (limited to 'databases/p5-DBIx-Class-Tree')
-rw-r--r--databases/p5-DBIx-Class-Tree/Makefile27
-rw-r--r--databases/p5-DBIx-Class-Tree/distinfo2
-rw-r--r--databases/p5-DBIx-Class-Tree/pkg-descr11
-rw-r--r--databases/p5-DBIx-Class-Tree/pkg-plist7
4 files changed, 47 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Class-Tree/Makefile b/databases/p5-DBIx-Class-Tree/Makefile
new file mode 100644
index 000000000000..6abe0d48518c
--- /dev/null
+++ b/databases/p5-DBIx-Class-Tree/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: DBIx::Class::Tree
+# Date created: 17 Mar 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Class-Tree
+PORTVERSION= 0.03003
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to manipulate and anaylze tree structured data
+
+RUN_DEPENDS= \
+ p5-DBIx-Class>=0.08100:${PORTSDIR}/databases/p5-DBIx-Class
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Class::Tree.3 \
+ DBIx::Class::Tree::AdjacencyList.3 \
+ DBIx::Class::Tree::AdjacencyList::Ordered.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Class-Tree/distinfo b/databases/p5-DBIx-Class-Tree/distinfo
new file mode 100644
index 000000000000..3535d9073a64
--- /dev/null
+++ b/databases/p5-DBIx-Class-Tree/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DBIx-Class-Tree-0.03003.tar.gz) = 9f89ae00a201186911a2a7fcfc587d7c05d0945f9216785783d77b8b1561a423
+SIZE (DBIx-Class-Tree-0.03003.tar.gz) = 26348
diff --git a/databases/p5-DBIx-Class-Tree/pkg-descr b/databases/p5-DBIx-Class-Tree/pkg-descr
new file mode 100644
index 000000000000..0f7648d89f87
--- /dev/null
+++ b/databases/p5-DBIx-Class-Tree/pkg-descr
@@ -0,0 +1,11 @@
+This module provides methods for working with adjacency lists. The
+adjacency list model is a very common way of representing a tree
+structure. In this model each row in a table has a prent ID column
+that references the primary key of another row in the same table.
+Because of this the primary key must only be one column and is usually
+some sort of integer. The row with a parent ID of 0 is the root node
+and is usually the parent of all other rows. Although, there is no
+limitation in this module that would stop you from having multiple
+root nodes.
+
+WWW: http://search.cpan.org/dist/DBIx-Class-Tree/
diff --git a/databases/p5-DBIx-Class-Tree/pkg-plist b/databases/p5-DBIx-Class-Tree/pkg-plist
new file mode 100644
index 000000000000..265e3265531b
--- /dev/null
+++ b/databases/p5-DBIx-Class-Tree/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/Tree/.packlist
+%%SITE_PERL%%/DBIx/Class/Tree.pm
+%%SITE_PERL%%/DBIx/Class/Tree/AdjacencyList.pm
+%%SITE_PERL%%/DBIx/Class/Tree/AdjacencyList/Ordered.pm
+@dirrm %%SITE_PERL%%/DBIx/Class/Tree/AdjacencyList
+@dirrm %%SITE_PERL%%/DBIx/Class/Tree
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/Tree