aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Class-WebForm
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-02-11 17:51:24 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-02-11 17:51:24 +0000
commitc923f72f2b962f97e83af6f184ae6a7501ff2cfe (patch)
tree5a9174f581b20882ec9b2e7453ce26d44e2dd80e /databases/p5-DBIx-Class-WebForm
parentadc4b71ee35fa82609edf3f55627fdcbdbfa84fc (diff)
downloadports-c923f72f2b962f97e83af6f184ae6a7501ff2cfe.tar.gz
ports-c923f72f2b962f97e83af6f184ae6a7501ff2cfe.zip
Add p5-DBIx-Class-WebForm 0.02, CRUD methods for DBIx::Class.
PR: ports/93188 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
Notes
Notes: svn path=/head/; revision=155767
Diffstat (limited to 'databases/p5-DBIx-Class-WebForm')
-rw-r--r--databases/p5-DBIx-Class-WebForm/Makefile31
-rw-r--r--databases/p5-DBIx-Class-WebForm/distinfo3
-rw-r--r--databases/p5-DBIx-Class-WebForm/pkg-descr3
-rw-r--r--databases/p5-DBIx-Class-WebForm/pkg-plist3
4 files changed, 40 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Class-WebForm/Makefile b/databases/p5-DBIx-Class-WebForm/Makefile
new file mode 100644
index 000000000000..e3175891dec4
--- /dev/null
+++ b/databases/p5-DBIx-Class-WebForm/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: DBIx-Class-WebForm
+# Date created: 11 Feb 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Class-WebForm
+PORTVERSION= 0.02
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= CRUD methods for DBIx::Class
+
+BUILD_DEPENDS= p5-DBIx-Class>=0:${PORTSDIR}/databases/p5-DBIx-Class \
+ ${SITE_PERL}/HTML/Element.pm:${PORTSDIR}/www/p5-HTML-Tree \
+ ${SITE_PERL}/Data/FormValidator.pm:${PORTSDIR}/textproc/p5-Data-FormValidator
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= DBIx::Class::WebForm.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/databases/p5-DBIx-Class-WebForm/distinfo b/databases/p5-DBIx-Class-WebForm/distinfo
new file mode 100644
index 000000000000..ce165d3eb96d
--- /dev/null
+++ b/databases/p5-DBIx-Class-WebForm/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBIx-Class-WebForm-0.02.tar.gz) = 3fe470d41affd66f5c1e60716163e6be
+SHA256 (DBIx-Class-WebForm-0.02.tar.gz) = 5fa5b32de9f6154545112691b11f2f43a4cf5eb504fbf75da7793cc6c923b625
+SIZE (DBIx-Class-WebForm-0.02.tar.gz) = 3551
diff --git a/databases/p5-DBIx-Class-WebForm/pkg-descr b/databases/p5-DBIx-Class-WebForm/pkg-descr
new file mode 100644
index 000000000000..c45fa6cec728
--- /dev/null
+++ b/databases/p5-DBIx-Class-WebForm/pkg-descr
@@ -0,0 +1,3 @@
+CRUD methods for DBIx::Class
+
+WWW: http://search.cpan.org/dist/DBIx-Class-WebForm/
diff --git a/databases/p5-DBIx-Class-WebForm/pkg-plist b/databases/p5-DBIx-Class-WebForm/pkg-plist
new file mode 100644
index 000000000000..5ae140748f8e
--- /dev/null
+++ b/databases/p5-DBIx-Class-WebForm/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/DBIx/Class/WebForm.pm
+@dirrmtry %%SITE_PERL%%/DBIx/Class
+@dirrmtry %%SITE_PERL%%/DBIx