aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Simple
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-11 12:41:55 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-11 12:41:55 +0000
commite8e1270052973c2e350559a0c84b1db518151cd5 (patch)
tree2bf9dd253dc8db32553b86181d700d2dc3a6597c /databases/p5-DBIx-Simple
parentd3d48e1a43ccc4a9b18d42e11a55e77dc5f44048 (diff)
downloadports-e8e1270052973c2e350559a0c84b1db518151cd5.tar.gz
ports-e8e1270052973c2e350559a0c84b1db518151cd5.zip
DBIx::Simple module aims to be a simplified object oriented interface to Perl
DBI. From its description ... Query preparation and execution are combined in a single method, the result object (which is a wrapper around the statement handle) provides easy row-by-row and slurping methods. The "query" method returns either a result object, or a dummy object. The dummy object returns undef (or an empty list) for all methods and when used in boolean context, is false. The dummy object lets you postpone (or skip) error checking, but it also makes immediate error check simply " $db->query(...) or die $db->error". WWW: http://search.cpan.org/dist/DBIx-Simple/ PR: ports/90230 Submitted by: Parv <parv@pair.org>
Notes
Notes: svn path=/head/; revision=150872
Diffstat (limited to 'databases/p5-DBIx-Simple')
-rw-r--r--databases/p5-DBIx-Simple/Makefile46
-rw-r--r--databases/p5-DBIx-Simple/distinfo3
-rw-r--r--databases/p5-DBIx-Simple/pkg-descr14
-rw-r--r--databases/p5-DBIx-Simple/pkg-plist9
4 files changed, 72 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Simple/Makefile b/databases/p5-DBIx-Simple/Makefile
new file mode 100644
index 000000000000..001b40271237
--- /dev/null
+++ b/databases/p5-DBIx-Simple/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: DBIx::Simple
+# Date created: 10 December 2005
+# Whom: Parv <parv@pair.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Simple
+PORTVERSION= 1.26
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= parv@pair.com
+COMMENT= Simplified object oriented interface to Perl DBI
+
+RUN_DEPENDS= p5-DBI>=1.21:${PORTSDIR}/databases/p5-DBI \
+ p5-Data-Swap>=0.02:${PORTSDIR}/devel/p5-Data-Swap
+
+.if defined(WITH_SQL_ABSTRACT)
+RUN_DEPENDS+= p5-SQL-Abstract>=0:${PORTSDIR}/databases/p5-SQL-Abstract
+.endif
+
+.if defined(WITH_DBIX_XHTML_TABLE)
+RUN_DEPENDS+= p5-DBIx-XHTML_Table>=0:${PORTSDIR}/databases/p5-DBIx-XHTML_Table
+.endif
+
+.if defined(WITH_TEXT_TABLE)
+RUN_DEPENDS+= p5-Text-Table>=0:${PORTSDIR}/textproc/p5-Text-Table
+.endif
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Simple.3 \
+ DBIx::Simple::Examples.3 \
+ DBIx::Simple::Comparison.3 \
+ DBIx::Simple::SQE.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= need at least Perl 5.6; install lang/perl or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-DBIx-Simple/distinfo b/databases/p5-DBIx-Simple/distinfo
new file mode 100644
index 000000000000..de590f51707c
--- /dev/null
+++ b/databases/p5-DBIx-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBIx-Simple-1.26.tar.gz) = 47e4a2780fb27139e4b8d2c13c28ba13
+SHA256 (DBIx-Simple-1.26.tar.gz) = cf69682d844b313fbe68c003704d102c22df995367033a6da4e11ef5789af63c
+SIZE (DBIx-Simple-1.26.tar.gz) = 15869
diff --git a/databases/p5-DBIx-Simple/pkg-descr b/databases/p5-DBIx-Simple/pkg-descr
new file mode 100644
index 000000000000..a1bf8673126f
--- /dev/null
+++ b/databases/p5-DBIx-Simple/pkg-descr
@@ -0,0 +1,14 @@
+DBIx::Simple module aims to be a simplified object oriented interface to Perl
+DBI. From its description ...
+
+ Query preparation and execution are combined in a single method, the result
+ object (which is a wrapper around the statement handle) provides easy
+ row-by-row and slurping methods.
+
+ The "query" method returns either a result object, or a dummy object. The
+ dummy object returns undef (or an empty list) for all methods and when used in
+ boolean context, is false. The dummy object lets you postpone (or skip) error
+ checking, but it also makes immediate error check simply " $db->query(...) or
+ die $db->error".
+
+WWW: http://search.cpan.org/dist/DBIx-Simple/
diff --git a/databases/p5-DBIx-Simple/pkg-plist b/databases/p5-DBIx-Simple/pkg-plist
new file mode 100644
index 000000000000..ab32d43bf8bc
--- /dev/null
+++ b/databases/p5-DBIx-Simple/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/DBIx/Simple.pm
+%%SITE_PERL%%/DBIx/Simple/Comparison.pod
+%%SITE_PERL%%/DBIx/Simple/Examples.pod
+%%SITE_PERL%%/DBIx/Simple/SQE.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Simple/.packlist
+@dirrm %%SITE_PERL%%/DBIx/Simple
+@unexec rmdir %D/%%SITE_PERL%%/DBIx 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Simple
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx 2>/dev/null || true