aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Tree
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-05 02:24:52 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-05 02:24:52 +0000
commit40c0abdb5ba6ae8af1e1a32534e8b67f259541ae (patch)
tree0da9432c63c2f4d570ec24ba209c4bfd5271e628 /databases/p5-DBIx-Tree
parentb8e1e1600559c8a8b64cb58701d319c87504c1c9 (diff)
downloadports-40c0abdb5ba6ae8af1e1a32534e8b67f259541ae.tar.gz
ports-40c0abdb5ba6ae8af1e1a32534e8b67f259541ae.zip
New Port: databases/p5-DBIx-Tree v0.91
When you've got one of those nasty self-referential tables that you want to bust out into a tree, this is the module to check out. Assuming there are no horribly broken nodes in your tree and (heaven forbid) any circular references PR: ports/47660 Submitted by: Philip M. Gollucci <philip@p6m7g8.com>
Notes
Notes: svn path=/head/; revision=74733
Diffstat (limited to 'databases/p5-DBIx-Tree')
-rw-r--r--databases/p5-DBIx-Tree/Makefile25
-rw-r--r--databases/p5-DBIx-Tree/distinfo1
-rw-r--r--databases/p5-DBIx-Tree/pkg-comment1
-rw-r--r--databases/p5-DBIx-Tree/pkg-descr8
-rw-r--r--databases/p5-DBIx-Tree/pkg-plist9
5 files changed, 44 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Tree/Makefile b/databases/p5-DBIx-Tree/Makefile
new file mode 100644
index 000000000000..2ce97c5860d4
--- /dev/null
+++ b/databases/p5-DBIx-Tree/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-DBIx-Tree
+# Date created: January 29th 2003
+# Whom: Philip M. Gollucci <philip@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Tree
+PORTVERSION= 0.91
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= philip@p6m7g8.com
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+
+PERL_CONFIGURE= yes
+IS_INTERACTIVE= yes
+
+MAN3= DBIx::Tree.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Tree/distinfo b/databases/p5-DBIx-Tree/distinfo
new file mode 100644
index 000000000000..25277e526a24
--- /dev/null
+++ b/databases/p5-DBIx-Tree/distinfo
@@ -0,0 +1 @@
+MD5 (DBIx-Tree-0.91.tar.gz) = 945d2229738c525dc09b838690a2ce42
diff --git a/databases/p5-DBIx-Tree/pkg-comment b/databases/p5-DBIx-Tree/pkg-comment
new file mode 100644
index 000000000000..5de5e9cf8d15
--- /dev/null
+++ b/databases/p5-DBIx-Tree/pkg-comment
@@ -0,0 +1 @@
+Perl module for generating a tree from a self-referential table
diff --git a/databases/p5-DBIx-Tree/pkg-descr b/databases/p5-DBIx-Tree/pkg-descr
new file mode 100644
index 000000000000..941378d5547f
--- /dev/null
+++ b/databases/p5-DBIx-Tree/pkg-descr
@@ -0,0 +1,8 @@
+When you've got one of those nasty self-referential tables that you
+want to bust out into a tree, this is the module to check out. Assum-
+ing there are no horribly broken nodes in your tree and (heaven forbid)
+any circular references
+
+WWW: http://search.cpan.org/search?dist=DBIx-Tree
+
+Philip M. Gollucci <philip@p6m7g8.com>
diff --git a/databases/p5-DBIx-Tree/pkg-plist b/databases/p5-DBIx-Tree/pkg-plist
new file mode 100644
index 000000000000..97198ff3d165
--- /dev/null
+++ b/databases/p5-DBIx-Tree/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/auto/DBIx/Tree/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/DBIx/Tree
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBIx/Tree/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBIx/Tree
+lib/perl5/site_perl/%%PERL_VER%%/DBIx/Tree.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/mach/auto/DBIx 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/DBIx 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/DBIx 2>/dev/null || true
+