aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBM-Deep
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-02-01 17:01:32 +0000
committerSteve Wills <swills@FreeBSD.org>2012-02-01 17:01:32 +0000
commit4c1cf383fead0f0daa171c0c57cb46883ad71045 (patch)
tree26e678d921bb30aa3d0fa72cb6170996b7e6cba5 /databases/p5-DBM-Deep
parent5493c88cf6a285a27aefb4ba158eccfe3fb8c5bc (diff)
downloadports-4c1cf383fead0f0daa171c0c57cb46883ad71045.tar.gz
ports-4c1cf383fead0f0daa171c0c57cb46883ad71045.zip
- Add BUILD_DEPENDS to silence build warnings
- Don't use unecessary += for DEPENDS - Add TEST_DEPENDS to enable testing PR: ports/164486 Submitted by: swills (myself) Approved by: Mohacsi Janos <janos.mohacsi@bsd.hu> (maintainer)
Notes
Notes: svn path=/head/; revision=290237
Diffstat (limited to 'databases/p5-DBM-Deep')
-rw-r--r--databases/p5-DBM-Deep/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/databases/p5-DBM-Deep/Makefile b/databases/p5-DBM-Deep/Makefile
index 727bd928e668..d2efe45aedf5 100644
--- a/databases/p5-DBM-Deep/Makefile
+++ b/databases/p5-DBM-Deep/Makefile
@@ -14,13 +14,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= A pure perl persistent multi-level hash/array DBM
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/FileHandle/Fmode.pm:${PORTSDIR}/devel/p5-FileHandle-Fmode
-RUN_DEPENDS+= p5-Scalar-List-Utils>=1.14:${PORTSDIR}/lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= p5-IO-stringy>=0.01:${PORTSDIR}/devel/p5-IO-stringy
-RUN_DEPENDS+= p5-Test-Exception>=0.21:${PORTSDIR}/devel/p5-Test-Exception
-RUN_DEPENDS+= p5-Test-Warn>=0.08:${PORTSDIR}/devel/p5-Test-Warn
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone \
+ ${SITE_PERL}/${PERL_ARCH}/FileHandle/Fmode.pm:${PORTSDIR}/devel/p5-FileHandle-Fmode \
+ p5-Scalar-List-Utils>=1.14:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-IO-stringy>=0.01:${PORTSDIR}/devel/p5-IO-stringy
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone \
+ ${SITE_PERL}/${PERL_ARCH}/FileHandle/Fmode.pm:${PORTSDIR}/devel/p5-FileHandle-Fmode \
+ p5-Scalar-List-Utils>=1.14:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-IO-stringy>=0.01:${PORTSDIR}/devel/p5-IO-stringy
+TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Exception>=0.21:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-Warn>=0.08:${PORTSDIR}/devel/p5-Test-Warn
MAN3= DBM::Deep.3 DBM::Deep::Cookbook.3 DBM::Deep::Internals.3 \
DBM::Deep::Iterator::File::BucketList.3 \