aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Data-Pageset
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-30 21:36:32 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-30 21:36:32 +0000
commit00d556cf822c0bf97f38819c23c8d7e768096600 (patch)
tree764a455b5af97a690f338fb9d0378d3ef7538c1d /databases/p5-Data-Pageset
parentc46be8e47c895dbe4135d8db8440f95cad28256d (diff)
downloadports-00d556cf822c0bf97f38819c23c8d7e768096600.tar.gz
ports-00d556cf822c0bf97f38819c23c8d7e768096600.zip
Adding port databases/p5-Data-Pageset, a module for manipulating multiple pages of returned data as well as sets of pages.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=164008
Diffstat (limited to 'databases/p5-Data-Pageset')
-rw-r--r--databases/p5-Data-Pageset/Makefile31
-rw-r--r--databases/p5-Data-Pageset/distinfo2
-rw-r--r--databases/p5-Data-Pageset/pkg-descr16
-rw-r--r--databases/p5-Data-Pageset/pkg-plist5
4 files changed, 54 insertions, 0 deletions
diff --git a/databases/p5-Data-Pageset/Makefile b/databases/p5-Data-Pageset/Makefile
new file mode 100644
index 000000000000..d7412b383c9a
--- /dev/null
+++ b/databases/p5-Data-Pageset/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Data-Pageset
+# Date created: 29 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Pageset
+PORTVERSION= 1.03
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Page numbering and page sets
+
+BUILD_DEPENDS= ${SITE_PERL}/Data/Page.pm:${PORTSDIR}/databases/p5-Data-Page
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Data::Pageset.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-Data-Pageset/distinfo b/databases/p5-Data-Pageset/distinfo
new file mode 100644
index 000000000000..c21af3e10b55
--- /dev/null
+++ b/databases/p5-Data-Pageset/distinfo
@@ -0,0 +1,2 @@
+MD5 (Data-Pageset-1.03.tar.gz) = 5175f54b07abf7b68740c3f452c49505
+SIZE (Data-Pageset-1.03.tar.gz) = 7035
diff --git a/databases/p5-Data-Pageset/pkg-descr b/databases/p5-Data-Pageset/pkg-descr
new file mode 100644
index 000000000000..ff6305828a70
--- /dev/null
+++ b/databases/p5-Data-Pageset/pkg-descr
@@ -0,0 +1,16 @@
+The object produced by Data::Pageset can be used to create page
+navigation, it inherits from Data::Page and has access to all methods from
+this object.
+
+In addition it also provides methods for dealing with set of pages, so
+that if there are too many pages you can easily break them into chunks for
+the user to browse through.
+
+You can even choose to view page numbers in your set in a 'sliding'
+fassion.
+
+The object can easily be passed to a templating system such as Template
+Toolkit or be used within a script.
+
+WWW: http://search.cpan.org/dist/Data-Pageset
+Author: Leo Lapworth <LLAP@cuckoo.org>
diff --git a/databases/p5-Data-Pageset/pkg-plist b/databases/p5-Data-Pageset/pkg-plist
new file mode 100644
index 000000000000..57faf9d67762
--- /dev/null
+++ b/databases/p5-Data-Pageset/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Data/Pageset.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Pageset/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Pageset
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data