aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-File-Locate
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2017-02-17 20:49:22 +0000
committerKurt Jaeger <pi@FreeBSD.org>2017-02-17 20:49:22 +0000
commit5b7d4741fbd9879a56a0e03e29def04d2ff2f8ea (patch)
treea0e06b0a092ea7684a5451814e6fb4af3877e1f9 /databases/p5-File-Locate
parentde481b1e2811251dde1c4d5e964fcaa4da379860 (diff)
Notes
Diffstat (limited to 'databases/p5-File-Locate')
-rw-r--r--databases/p5-File-Locate/Makefile22
-rw-r--r--databases/p5-File-Locate/distinfo3
-rw-r--r--databases/p5-File-Locate/files/patch-Locate.xs44
-rw-r--r--databases/p5-File-Locate/pkg-descr6
4 files changed, 75 insertions, 0 deletions
diff --git a/databases/p5-File-Locate/Makefile b/databases/p5-File-Locate/Makefile
new file mode 100644
index 000000000000..f8ea74e9e715
--- /dev/null
+++ b/databases/p5-File-Locate/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= File-Locate
+PORTVERSION= 0.62
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Search the locate(1)-database from Perl
+
+LICENSE= GPLv2+
+
+USES= perl5
+USE_PERL5= configure
+
+PLIST_FILES= %%SITE_ARCH%%/File/Locate.pm \
+ %%SITE_ARCH%%/auto/File/Locate/Locate.so \
+ %%SITE_ARCH%%/auto/File/Locate/autosplit.ix \
+ %%PERL5_MAN3%%/File::Locate.3.gz
+
+.include <bsd.port.mk>
diff --git a/databases/p5-File-Locate/distinfo b/databases/p5-File-Locate/distinfo
new file mode 100644
index 000000000000..96e64001768b
--- /dev/null
+++ b/databases/p5-File-Locate/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1487361878
+SHA256 (File-Locate-0.62.tar.gz) = 8565f067b3ba285f6ba8a4e2939a02ba37be82d6d37e420c61f1f85825f2a3d0
+SIZE (File-Locate-0.62.tar.gz) = 21343
diff --git a/databases/p5-File-Locate/files/patch-Locate.xs b/databases/p5-File-Locate/files/patch-Locate.xs
new file mode 100644
index 000000000000..7593a77fd81d
--- /dev/null
+++ b/databases/p5-File-Locate/files/patch-Locate.xs
@@ -0,0 +1,44 @@
+--- Locate.xs.orig 2007-02-17 13:56:53 UTC
++++ Locate.xs
+@@ -48,7 +48,8 @@ extern int errno;
+ uid_t UID;
+ gid_t GID;
+
+-typedef enum {false, true} boolean;
++// typedef enum {false, true} boolean;
++#include <stdbool.h>
+
+ static char * last_literal_end (char *name) {
+ static char *globfree = NULL; /* A copy of the subpattern in NAME. */
+@@ -247,7 +248,7 @@ _locate (pathpart, ...)
+ FILE *fp; /* The pathname database. */
+ int c; /* An input byte. */
+ int nread; /* Number of bytes read from an entry. */
+- boolean globflag; /* true if PATHPART contains globbing
++ bool globflag; /* true if PATHPART contains globbing
+ metacharacters. */
+ char *patend; /* The end of the last glob-free subpattern
+ in PATHPART. */
+@@ -258,11 +259,11 @@ _locate (pathpart, ...)
+ char *cutoff; /* Where in `path' to stop the backward search for
+ the last character in the subpattern. Set
+ according to `count'. */
+- boolean prev_fast_match = false; /* true if we found a fast match
++ bool prev_fast_match = false; /* true if we found a fast match
+ (of patend) on the previous
+ path. */
+ int printed = 0; /* The return value. */
+- boolean old_format = false; /* true if reading a bigram-encoded
++ bool old_format = false; /* true if reading a bigram-encoded
+ database. */
+ char bigram1[128], bigram2[128]; /* For the old database format, the
+ first and second characters of
+@@ -511,7 +512,7 @@ _slocate (str, ...)
+ char slevel = '1';
+ int res = 0;
+
+- boolean prev_fast_match = false; /* true if we found a fast match
++ bool prev_fast_match = false; /* true if we found a fast match
+ (of patend) on the previous
+ path. */
+ register int i;
diff --git a/databases/p5-File-Locate/pkg-descr b/databases/p5-File-Locate/pkg-descr
new file mode 100644
index 000000000000..a38bfd320ec2
--- /dev/null
+++ b/databases/p5-File-Locate/pkg-descr
@@ -0,0 +1,6 @@
+File::Locate provides the locate() function that scans the locate
+database for a given substring or POSIX regular expression. The
+module can handle both plain old locate databases as well as the
+more hip slocate format.
+
+WWW: http://search.cpan.org/dist/File-Locate/