aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-GDBM
diff options
context:
space:
mode:
authorNick Sayer <nsayer@FreeBSD.org>1999-11-09 19:07:57 +0000
committerNick Sayer <nsayer@FreeBSD.org>1999-11-09 19:07:57 +0000
commit310ba58c61dfbc2e2ad895b8ced4b8bcd32894e2 (patch)
tree180f4ccb9eecff134ce6a324f4fda80726b7a7e7 /databases/p5-GDBM
parent329cba84375ebe744a1ff9aa2afb2c437d1f65ea (diff)
downloadports-310ba58c61dfbc2e2ad895b8ced4b8bcd32894e2.tar.gz
ports-310ba58c61dfbc2e2ad895b8ced4b8bcd32894e2.zip
Add p5-GDBM port. Sort of a merge of my first cut at it and another
from eivind.
Notes
Notes: svn path=/head/; revision=22992
Diffstat (limited to 'databases/p5-GDBM')
-rw-r--r--databases/p5-GDBM/Makefile33
-rw-r--r--databases/p5-GDBM/distinfo1
-rw-r--r--databases/p5-GDBM/files/patch-aa10
-rw-r--r--databases/p5-GDBM/pkg-comment1
-rw-r--r--databases/p5-GDBM/pkg-descr6
-rw-r--r--databases/p5-GDBM/pkg-plist6
6 files changed, 57 insertions, 0 deletions
diff --git a/databases/p5-GDBM/Makefile b/databases/p5-GDBM/Makefile
new file mode 100644
index 000000000000..daf48fcf17eb
--- /dev/null
+++ b/databases/p5-GDBM/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-GDBM
+# Version required: 1.0
+# Date created: Nov 9 1999
+# Whom: Nick Sayer <nsayer@FreeBSD.ORG>
+#
+# Heavy input from eivind@freebsd.org
+#
+# $FreeBSD$
+#
+
+DISTNAME= perl5.005_03
+PKGNAME= p5-GDBM-1.00
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../src
+
+MAINTAINER= nsayer@FreeBSD.ORG
+
+LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm
+
+USE_PERL5= YES
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/ext/GDBM_File
+
+MAN3= GDBM_File.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.pre.mk>
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-GDBM/distinfo b/databases/p5-GDBM/distinfo
new file mode 100644
index 000000000000..cf1e8eb72c19
--- /dev/null
+++ b/databases/p5-GDBM/distinfo
@@ -0,0 +1 @@
+MD5 (perl5.005_03.tar.gz) = 427890d97e32430341c1fa80f55277a7
diff --git a/databases/p5-GDBM/files/patch-aa b/databases/p5-GDBM/files/patch-aa
new file mode 100644
index 000000000000..37db1923f1b4
--- /dev/null
+++ b/databases/p5-GDBM/files/patch-aa
@@ -0,0 +1,10 @@
+--- Makefile.PL.orig Tue Nov 9 09:03:15 1999
++++ Makefile.PL Tue Nov 9 08:13:45 1999
+@@ -2,7 +2,7 @@
+ use ExtUtils::MakeMaker;
+ WriteMakefile(
+ NAME => 'GDBM_File',
++ INC => '-I/usr/local/include',
+ LIBS => ["-L/usr/local/lib -lgdbm", "-ldbm"],
+- MAN3PODS => {}, # Pods will be built by installman.
+ XSPROTOARG => '-noprototypes', # XXX remove later?
diff --git a/databases/p5-GDBM/pkg-comment b/databases/p5-GDBM/pkg-comment
new file mode 100644
index 000000000000..38c6ff446672
--- /dev/null
+++ b/databases/p5-GDBM/pkg-comment
@@ -0,0 +1 @@
+Perl module to use the GNU Data Base Manager (gdbm)
diff --git a/databases/p5-GDBM/pkg-descr b/databases/p5-GDBM/pkg-descr
new file mode 100644
index 000000000000..9fa0af2eef08
--- /dev/null
+++ b/databases/p5-GDBM/pkg-descr
@@ -0,0 +1,6 @@
+GDBM_File is a perl module which allows Perl programs to make use of the
+facilities provided by the GNU gdbm library. If you intend to use this
+module you should really have a copy of the gdbm manualpage at hand.
+
+Most of the libgdbm.a functions are available through the GDBM_File
+interface.
diff --git a/databases/p5-GDBM/pkg-plist b/databases/p5-GDBM/pkg-plist
new file mode 100644
index 000000000000..c8fe2a5a19b6
--- /dev/null
+++ b/databases/p5-GDBM/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/GDBM_File.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GDBM_File/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GDBM_File/GDBM_File.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GDBM_File/GDBM_File.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GDBM_File/autosplit.ix
+@dirrm lib/perl5/site_perl/5.005/i386-freebsd/auto/GDBM_File