aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Mojo-Pg
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-02-21 16:30:34 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-02-21 16:30:34 +0000
commitae2170cacfdabd538abf064a3d0017c6ce47bdcf (patch)
tree35670fa0c40ae05c0934f24a08ee8f7e46082d34 /databases/p5-Mojo-Pg
parent4f486576336ff879fe09a934d94c451546bafdf7 (diff)
downloadports-ae2170cacfdabd538abf064a3d0017c6ce47bdcf.tar.gz
ports-ae2170cacfdabd538abf064a3d0017c6ce47bdcf.zip
Notes
Diffstat (limited to 'databases/p5-Mojo-Pg')
-rw-r--r--databases/p5-Mojo-Pg/Makefile23
-rw-r--r--databases/p5-Mojo-Pg/distinfo2
-rw-r--r--databases/p5-Mojo-Pg/pkg-descr8
-rw-r--r--databases/p5-Mojo-Pg/pkg-plist12
4 files changed, 45 insertions, 0 deletions
diff --git a/databases/p5-Mojo-Pg/Makefile b/databases/p5-Mojo-Pg/Makefile
new file mode 100644
index 000000000000..98098d5ca610
--- /dev/null
+++ b/databases/p5-Mojo-Pg/Makefile
@@ -0,0 +1,23 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Mojo-Pg
+PORTVERSION= 1.10
+CATEGORIES= databases www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:SRI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= PostgreSQL integration for p5-Mojolicious
+
+LICENSE= ART20
+
+BUILD_DEPENDS= p5-Mojolicious>=5.81:${PORTSDIR}/www/p5-Mojolicious \
+ p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Mojo-Pg/distinfo b/databases/p5-Mojo-Pg/distinfo
new file mode 100644
index 000000000000..e78fc30c4d0a
--- /dev/null
+++ b/databases/p5-Mojo-Pg/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Mojo-Pg-1.10.tar.gz) = d276e47b160ea347820a0397b3e4dfaa4fb652de70b09b1be06854f5802d18b6
+SIZE (Mojo-Pg-1.10.tar.gz) = 20094
diff --git a/databases/p5-Mojo-Pg/pkg-descr b/databases/p5-Mojo-Pg/pkg-descr
new file mode 100644
index 000000000000..779132b3760c
--- /dev/null
+++ b/databases/p5-Mojo-Pg/pkg-descr
@@ -0,0 +1,8 @@
+Mojo::Pg is a tiny wrapper around DBD::Pg that makes PostgreSQL a lot of fun to
+use with the Mojolicious real-time web framework.
+
+Database handles are cached automatically, so they can be reused transparently
+to increase performance. And you can handle connection timeouts gracefully by
+holding on to them only for short amounts of time.
+
+WWW: http://mojolicio.us/perldoc/Mojo/Pg
diff --git a/databases/p5-Mojo-Pg/pkg-plist b/databases/p5-Mojo-Pg/pkg-plist
new file mode 100644
index 000000000000..512f0538782c
--- /dev/null
+++ b/databases/p5-Mojo-Pg/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/Mojo/Pg.pm
+%%SITE_PERL%%/Mojo/Pg/Database.pm
+%%SITE_PERL%%/Mojo/Pg/Migrations.pm
+%%SITE_PERL%%/Mojo/Pg/PubSub.pm
+%%SITE_PERL%%/Mojo/Pg/Results.pm
+%%SITE_PERL%%/Mojo/Pg/Transaction.pm
+%%PERL5_MAN3%%/Mojo::Pg.3.gz
+%%PERL5_MAN3%%/Mojo::Pg::Database.3.gz
+%%PERL5_MAN3%%/Mojo::Pg::Migrations.3.gz
+%%PERL5_MAN3%%/Mojo::Pg::PubSub.3.gz
+%%PERL5_MAN3%%/Mojo::Pg::Results.3.gz
+%%PERL5_MAN3%%/Mojo::Pg::Transaction.3.gz