aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-POE-Component-DBIAgent/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2007-06-30 09:48:39 +0000
committerErwin Lansing <erwin@FreeBSD.org>2007-06-30 09:48:39 +0000
commitaa902953d1abacf75a974bcc6ddb0d127ccfbcc0 (patch)
treece7521dbe765d571c5de32477b8ab943eb557043 /databases/p5-POE-Component-DBIAgent/Makefile
parentf707a510eb9490aacde7147902054f9d74981470 (diff)
downloadports-aa902953d1abacf75a974bcc6ddb0d127ccfbcc0.tar.gz
ports-aa902953d1abacf75a974bcc6ddb0d127ccfbcc0.zip
Notes
Diffstat (limited to 'databases/p5-POE-Component-DBIAgent/Makefile')
-rw-r--r--databases/p5-POE-Component-DBIAgent/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/databases/p5-POE-Component-DBIAgent/Makefile b/databases/p5-POE-Component-DBIAgent/Makefile
index b381b7a782f9..424a84dd689b 100644
--- a/databases/p5-POE-Component-DBIAgent/Makefile
+++ b/databases/p5-POE-Component-DBIAgent/Makefile
@@ -17,7 +17,8 @@ COMMENT= POE Component for running asynchronous DBI calls
BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/${PERL_ARCH}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
+ ${SITE_PERL}/${PERL_ARCH}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -25,14 +26,4 @@ PERL_CONFIGURE= yes
MAN3= POE::Component::DBIAgent.3 POE::Component::DBIAgent::Helper.3 \
POE::Component::DBIAgent::Queue.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>