aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-POE-Component-LaDBI
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-03-30 15:50:30 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-03-30 15:50:30 +0000
commitf07849a27d3b17cc4497f67f810212b4802d754a (patch)
tree9b29db0e6f318fa6fa2c3fa4fb91909c979619fc /databases/p5-POE-Component-LaDBI
parent4350c75ac8b75e5c8372dd681de5a688d1aa1f80 (diff)
downloadports-f07849a27d3b17cc4497f67f810212b4802d754a.tar.gz
ports-f07849a27d3b17cc4497f67f810212b4802d754a.zip
Add p5-POE-Component-LaDBI 1.2.0,
perl extension for asynchronous non-blocking DBI calls in POE.
Notes
Notes: svn path=/head/; revision=105711
Diffstat (limited to 'databases/p5-POE-Component-LaDBI')
-rw-r--r--databases/p5-POE-Component-LaDBI/Makefile41
-rw-r--r--databases/p5-POE-Component-LaDBI/distinfo2
-rw-r--r--databases/p5-POE-Component-LaDBI/files/patch-Makefile.PL19
-rw-r--r--databases/p5-POE-Component-LaDBI/pkg-descr7
-rw-r--r--databases/p5-POE-Component-LaDBI/pkg-plist12
5 files changed, 81 insertions, 0 deletions
diff --git a/databases/p5-POE-Component-LaDBI/Makefile b/databases/p5-POE-Component-LaDBI/Makefile
new file mode 100644
index 000000000000..8418a23071ec
--- /dev/null
+++ b/databases/p5-POE-Component-LaDBI/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: POE-Component-LaDBI
+# Date created: 09 February 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-LaDBI
+PORTVERSION= 1.2.0
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Perl extension for asynchronous non-blocking DBI calls in POE
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::LaDBI.3 POE::Component::LaDBI::Commands.3 \
+ POE::Component::LaDBI::Engine.3 \
+ POE::Component::LaDBI::Request.3 \
+ POE::Component::LaDBI::Response.3
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ ${RM} ${WRKSRC}/*.pl
+
+post-patch:
+ @${PERL} -pi -e 's!(?=read_answer_yes\()!0 and !;' ${WRKSRC}/Makefile.PL
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "Perl 5.6 or newer required. Install lang/perl5.8 or lang/perl5 and try again."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-POE-Component-LaDBI/distinfo b/databases/p5-POE-Component-LaDBI/distinfo
new file mode 100644
index 000000000000..243bf2f6a506
--- /dev/null
+++ b/databases/p5-POE-Component-LaDBI/distinfo
@@ -0,0 +1,2 @@
+MD5 (POE-Component-LaDBI-1.2.0.tar.gz) = 2de7741c35f7289b4ddb120cf1868116
+SIZE (POE-Component-LaDBI-1.2.0.tar.gz) = 24655
diff --git a/databases/p5-POE-Component-LaDBI/files/patch-Makefile.PL b/databases/p5-POE-Component-LaDBI/files/patch-Makefile.PL
new file mode 100644
index 000000000000..c53401f28f43
--- /dev/null
+++ b/databases/p5-POE-Component-LaDBI/files/patch-Makefile.PL
@@ -0,0 +1,19 @@
+--- Makefile.PL.orig Tue Mar 30 19:41:17 2004
++++ Makefile.PL Tue Mar 30 19:42:44 2004
+@@ -9,7 +9,7 @@
+
+ our $BASE_CFG_FN;
+ our $NO_DB_TESTS_FN;
+-require "ladbi_config.pl";
++=for unused
+
+ if (0 and read_answer_yes("Do you want to test this module against a Database?"))
+ {
+@@ -42,6 +42,7 @@
+ }
+
+
++=cut
+
+ #exit 0;
+
diff --git a/databases/p5-POE-Component-LaDBI/pkg-descr b/databases/p5-POE-Component-LaDBI/pkg-descr
new file mode 100644
index 000000000000..d9863a3c2478
--- /dev/null
+++ b/databases/p5-POE-Component-LaDBI/pkg-descr
@@ -0,0 +1,7 @@
+POE Component that spawns a perl subprocess to handle non-blocking
+access to the DBI API.
+
+WWW: http://search.cpan.org/dist/POE-Component-LaDBI/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/databases/p5-POE-Component-LaDBI/pkg-plist b/databases/p5-POE-Component-LaDBI/pkg-plist
new file mode 100644
index 000000000000..4d2cc7a063c2
--- /dev/null
+++ b/databases/p5-POE-Component-LaDBI/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/LaDBI/.packlist
+%%SITE_PERL%%/POE/Component/LaDBI.pm
+%%SITE_PERL%%/POE/Component/LaDBI/Commands.pm
+%%SITE_PERL%%/POE/Component/LaDBI/Engine.pm
+%%SITE_PERL%%/POE/Component/LaDBI/Request.pm
+%%SITE_PERL%%/POE/Component/LaDBI/Response.pm
+@dirrm %%SITE_PERL%%/POE/Component/LaDBI
+@unexec rmdir %D/%%SITE_PERL%%/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/LaDBI
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true