aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Pg/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2002-02-19 08:25:15 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2002-02-19 08:25:15 +0000
commit61f5153809006c746686eec03511260960dbe458 (patch)
treefbbdc37b09d057787de2acc9ef62a86374054a70 /databases/p5-Pg/Makefile
parent0c0bcdc10ba6c2d0bbf6c831f5bc05a32470a2e7 (diff)
downloadports-61f5153809006c746686eec03511260960dbe458.tar.gz
ports-61f5153809006c746686eec03511260960dbe458.zip
Notes
Diffstat (limited to 'databases/p5-Pg/Makefile')
-rw-r--r--databases/p5-Pg/Makefile27
1 files changed, 18 insertions, 9 deletions
diff --git a/databases/p5-Pg/Makefile b/databases/p5-Pg/Makefile
index c363544a9bd0..90b52da5d0bb 100644
--- a/databases/p5-Pg/Makefile
+++ b/databases/p5-Pg/Makefile
@@ -6,23 +6,32 @@
#
PORTNAME= Pg
-PORTVERSION= 1.9.0
-PORTREVISION= 1
+POSTVERSION= 7.2
CATEGORIES= databases perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Pg
PKGNAMEPREFIX= p5-
-DISTNAME= pgsql_perl5-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= girgen@partitur.se
+
+POSTGRESQL_SUBPORT=YES
+.include <${.CURDIR}/../postgresql7/Makefile>
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
-PERL_CONFIGURE= yes
-CONFIGURE_ENV= POSTGRES_INCLUDE="${LOCALBASE}/include/pgsql -I${LOCALBASE}/pgsql/include" \
- POSTGRES_LIB="${LOCALBASE}/lib -L${LOCALBASE}/pgsql/lib"
+USE_PERL5= yes
+
+CONFIGURE_ARGS= --with-perl
MAN3= Pg.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAKE_ARGS+= -C src/interfaces/perl5
+MAKEFILE= GNUmakefile
+
+post-patch:
+ cd ${WRKSRC}/src/interfaces/perl5 ;\
+ cp GNUmakefile GNUmakefile.old ;\
+ ${SED} -e 's,\$$\$$abs_libpq_builddir,${LOCALBASE}/lib,; \
+ s,Makefile\ libpq-all,Makefile,' \
+ < GNUmakefile.old > GNUmakefile
+
.include <bsd.port.mk>