aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Pg
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
commit1e60866cc19e399726a715fe8f90de75614755d9 (patch)
tree919603a1bf324ecbe31827d6a9441e11e58f98a0 /databases/p5-Pg
parent30563b53998852429b379c5698be8bc307cc56ca (diff)
downloadports-1e60866cc19e399726a715fe8f90de75614755d9.tar.gz
ports-1e60866cc19e399726a715fe8f90de75614755d9.zip
Lots and lots of cleanups. Teach p5-* in general about PKGNAMEPREFIX.
Add some missing/wrong dependencies. Show how to respect CC/CFLAGS. Many miscellaneous modifications. I used more excessive hacks to force p5-Jcode and p5-WWW-Search to respect CC/CFLAGS. Patches largely done by: Christian Weisgerber <naddy@mips.inka.de>
Notes
Notes: svn path=/head/; revision=29658
Diffstat (limited to 'databases/p5-Pg')
-rw-r--r--databases/p5-Pg/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/databases/p5-Pg/Makefile b/databases/p5-Pg/Makefile
index 1740e4087799..4b2af7241ec7 100644
--- a/databases/p5-Pg/Makefile
+++ b/databases/p5-Pg/Makefile
@@ -5,18 +5,19 @@
# $FreeBSD$
#
-PORTNAME= p5-Pg
+PORTNAME= Pg
PORTVERSION= 1.8.1
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pg
DISTNAME= pgsql_perl5-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= jfitz@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/pgsql/lib/libpq.a:${PORTSDIR}/databases/postgresql
-USE_PERL5= YES
+USE_PERL5= yes
POSTGRES_HOME?= ${PREFIX}/pgsql
MAKE_ENV+= POSTGRES_HOME=${POSTGRES_HOME}
@@ -25,6 +26,7 @@ MAN3= Pg.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>