aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Prophet
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-06-10 15:06:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-06-10 15:06:51 +0000
commit87e9e9eee0c5ac9bc0e8af59379a2f48ee4e35ec (patch)
treec3cbfacbc1d4aea9b65ca835364e88816daac8db /databases/p5-Prophet
parent7e197e3600df16cbb8aa47a7128e4529ed258bea (diff)
downloadports-87e9e9eee0c5ac9bc0e8af59379a2f48ee4e35ec.tar.gz
ports-87e9e9eee0c5ac9bc0e8af59379a2f48ee4e35ec.zip
Update to 0.751.
Notes
Notes: svn path=/head/; revision=320485
Diffstat (limited to 'databases/p5-Prophet')
-rw-r--r--databases/p5-Prophet/Makefile118
-rw-r--r--databases/p5-Prophet/distinfo4
-rw-r--r--databases/p5-Prophet/pkg-plist2
3 files changed, 85 insertions, 39 deletions
diff --git a/databases/p5-Prophet/Makefile b/databases/p5-Prophet/Makefile
index bc864e5b69c3..14101db4b6c3 100644
--- a/databases/p5-Prophet/Makefile
+++ b/databases/p5-Prophet/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= Prophet
-PORTVERSION= 0.750
-PORTREVISION= 2
+PORTVERSION= 0.751
CATEGORIES= databases perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= CPAN:SPANG
+MASTER_SITE_SUBDIR= CPAN:IOANR
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
@@ -49,50 +48,97 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0.26:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
-MAN3= Prophet::Web::Result.3 \
- Prophet::Replica::prophet.3 \
+MAN1= prophet.1
+MAN3= Prophet.3 \
+ Prophet::App.3 \
+ Prophet::CLI.3 \
+ Prophet::CLI::CollectionCommand.3 \
+ Prophet::CLI::Command.3 \
+ Prophet::CLI::Command::Aliases.3 \
+ Prophet::CLI::Command::Clone.3 \
+ Prophet::CLI::Command::Config.3 \
+ Prophet::CLI::Command::Create.3 \
+ Prophet::CLI::Command::Delete.3 \
+ Prophet::CLI::Command::Export.3 \
+ Prophet::CLI::Command::History.3 \
+ Prophet::CLI::Command::Info.3 \
+ Prophet::CLI::Command::Init.3 \
+ Prophet::CLI::Command::Log.3 \
Prophet::CLI::Command::Merge.3 \
- Prophet::CLI::TextEditorCommand.3 \
- Prophet::UUIDGenerator.3 \
+ Prophet::CLI::Command::Mirror.3 \
+ Prophet::CLI::Command::Publish.3 \
Prophet::CLI::Command::Pull.3 \
- Prophet.3 \
+ Prophet::CLI::Command::Push.3 \
+ Prophet::CLI::Command::Search.3 \
+ Prophet::CLI::Command::Server.3 \
+ Prophet::CLI::Command::Settings.3 \
+ Prophet::CLI::Command::Shell.3 \
+ Prophet::CLI::Command::Show.3 \
+ Prophet::CLI::Command::Update.3 \
+ Prophet::CLI::Dispatcher.3 \
+ Prophet::CLI::Dispatcher::Rule.3 \
+ Prophet::CLI::Dispatcher::Rule::RecordId.3 \
+ Prophet::CLI::MirrorCommand.3 \
+ Prophet::CLI::Parameters.3 \
+ Prophet::CLI::ProgressBar.3 \
+ Prophet::CLI::PublishCommand.3 \
+ Prophet::CLI::RecordCommand.3 \
+ Prophet::CLI::TextEditorCommand.3 \
+ Prophet::CLIContext.3 \
+ Prophet::Change.3 \
Prophet::ChangeSet.3 \
- Prophet::Test::Editor.3 \
Prophet::Collection.3 \
- Prophet::CLI::RecordCommand.3 \
- Prophet::CLI::Command::Show.3 \
- Prophet::CLI.3 \
- Prophet::Server::ViewHelpers::Function.3 \
- Prophet::Server.3 \
- Prophet::Resolver::IdenticalChanges.3 \
- Prophet::Record.3 \
- Prophet::Manual.3 \
- Prophet::Util.3 \
- Prophet::Server::ViewHelpers::ParamFromFunction.3 \
Prophet::Config.3 \
- Prophet::Web::Menu.3 \
- Prophet::ConflictingPropChange.3 \
- Prophet::CLI::Command::Search.3 \
- Prophet::App.3 \
- Prophet::Server::Controller.3 \
- Prophet::Change.3 \
- Prophet::ForeignReplica.3 \
+ Prophet::Conflict.3 \
Prophet::ConflictingChange.3 \
- Prophet::CLI::Command::Clone.3 \
- Prophet::Replica.3 \
- Prophet::CLI::Command.3 \
+ Prophet::ConflictingPropChange.3 \
+ Prophet::ContentAddressedStore.3 \
+ Prophet::DatabaseSetting.3 \
Prophet::FilesystemReplica.3 \
- Prophet::Server::ViewHelpers::Widget.3 \
+ Prophet::ForeignReplica.3 \
+ Prophet::Manual.3 \
+ Prophet::Meta::Types.3 \
Prophet::PropChange.3 \
+ Prophet::Record.3 \
+ Prophet::Replica.3 \
+ Prophet::Replica::FS::Backend::File.3 \
+ Prophet::Replica::FS::Backend::LWP.3 \
+ Prophet::Replica::FS::Backend::SSH.3 \
+ Prophet::Replica::file.3 \
+ Prophet::Replica::http.3 \
+ Prophet::Replica::prophet.3 \
+ Prophet::Replica::prophet_cache.3 \
+ Prophet::Replica::sqlite.3 \
Prophet::ReplicaExporter.3 \
- Prophet::Conflict.3 \
- Prophet::CLI::Command::Log.3 \
+ Prophet::ReplicaFeedExporter.3 \
+ Prophet::Resolver.3 \
+ Prophet::Resolver::AlwaysSource.3 \
+ Prophet::Resolver::AlwaysTarget.3 \
+ Prophet::Resolver::Failed.3 \
+ Prophet::Resolver::Fixup::MissingSourceOldValues.3 \
+ Prophet::Resolver::FromResolutionDB.3 \
+ Prophet::Resolver::IdenticalChanges.3 \
+ Prophet::Resolver::Prompt.3 \
+ Prophet::Server.3 \
+ Prophet::Server::Controller.3 \
+ Prophet::Server::Dispatcher.3 \
+ Prophet::Server::View.3 \
+ Prophet::Server::ViewHelpers.3 \
+ Prophet::Server::ViewHelpers::Function.3 \
+ Prophet::Server::ViewHelpers::HiddenParam.3 \
+ Prophet::Server::ViewHelpers::ParamFromFunction.3 \
+ Prophet::Server::ViewHelpers::Widget.3 \
Prophet::Test.3 \
+ Prophet::Test::Arena.3 \
+ Prophet::Test::Editor.3 \
+ Prophet::Test::Participant.3 \
+ Prophet::UUIDGenerator.3 \
+ Prophet::Util.3 \
+ Prophet::Web::Field.3 \
Prophet::Web::FunctionResult.3 \
- Prophet::CLIContext.3 \
- Prophet::Replica::sqlite.3 \
- Prophet::Meta::Types.3
+ Prophet::Web::Menu.3 \
+ Prophet::Web::Result.3
.include <bsd.port.mk>
diff --git a/databases/p5-Prophet/distinfo b/databases/p5-Prophet/distinfo
index c552b3a5b087..2c8c84b0f703 100644
--- a/databases/p5-Prophet/distinfo
+++ b/databases/p5-Prophet/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Prophet-0.750.tar.gz) = c53d0223b068486d38e6e1fd9db76818dd318126638d6243ed018ee29857db87
-SIZE (Prophet-0.750.tar.gz) = 212359
+SHA256 (Prophet-0.751.tar.gz) = 3a37d3dea7989800b1e7502f573761c14ee97ee1d7c80066c979ebc2df87abe5
+SIZE (Prophet-0.751.tar.gz) = 208442
diff --git a/databases/p5-Prophet/pkg-plist b/databases/p5-Prophet/pkg-plist
index 5a8ec6ba8422..b3994e54d593 100644
--- a/databases/p5-Prophet/pkg-plist
+++ b/databases/p5-Prophet/pkg-plist
@@ -1,3 +1,4 @@
+bin/prophet
%%SITE_PERL%%/auto/share/dist/Prophet/web/static/jquery/css/superfish.css
%%SITE_PERL%%/auto/share/dist/Prophet/web/static/jquery/css/tablesorter/style.css
%%SITE_PERL%%/auto/share/dist/Prophet/web/static/jquery/css/superfish-vertical.css
@@ -20,7 +21,6 @@
%%SITE_PERL%%/auto/share/dist/Prophet/web/static/jquery/images/shadow.png
%%SITE_PERL%%/auto/share/dist/Prophet/web/static/jquery/images/arrows-cccccc.png
%%SITE_PERL%%/Prophet.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Prophet/.packlist
%%SITE_PERL%%/Prophet/Test.pm
%%SITE_PERL%%/Prophet/Resolver.pm
%%SITE_PERL%%/Prophet/Resolver/FromResolutionDB.pm